Subject: [alto] [Fwd: [dnsext] Re: I-D ACTION:draft-vandergaast-edns-client-ip-00.txt]

From: Enrico Marocco <[email-masked]>
Date: Fri, 29 Jan 2010 12:13:35 +0100

An interesting discussion about DNS-based load balancing -- a topic that
hit this list a few times -- is going on on the DNSEXT WG.

Anyone interested may join the WG list by sending an email with the
command "subscribe" in a single line in the message body to
[email-masked] (just clicking on
mailto:[email-masked]?body=subscribe should do the
magic).

Web archives are available at http://ops.ietf.org/lists/namedroppers/

Enrico

-------- Original Message --------
Subject: [dnsext] Re: I-D ACTION:draft-vandergaast-edns-client-ip-00.txt
Date: Thu, 28 Jan 2010 00:56:45 +0100
From: Wilmer van der Gaast <[email-masked]>
To: [email-masked] <[email-masked]>

Hello everyone,

I spoke to Olafur about this idea in Hiroshima last year. I'm afraid
the deadline for Anaheim already passed, but we hope we can discuss it
on-line in the meantime and decide if it should become a WG item in
Maastricht later this year.

To summarize the I-D: It specifies an EDNS0 option that carries IP
address information (by default only the first 24 bits to preserve
privacy) of the user that triggered a DNS resolution. This should
allow authoritative nameservers that give geo-targeted responses to be
more accurate, even in cases where the resolver and its users aren't
close to each other. To preserve the ability to cache such responses
efficiently, the option in the response can indicate which exact
subnet it should be cached for.

Comments are more than welcome.

Regards,

Wilmer van der Gaast
Carlo Contavalli
Google

Sean Leach
Darryl Rodden
Neustar/UltraDNS

>From i-d-announce:
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
>
>
> 	Title		: Client IP information in DNS requests
> 	Author(s)	: C. Contavalli, W. van der Gaast, S. Leach, D. Rodden
> 	Filename	: draft-vandergaast-edns-client-ip-00.txt
> 	Pages		: 20
> 	Date		: 2010-1-26
> 	
>    This draft defines an EDNS0 extension to allow Authoritative
>    Nameservers to return varying replies based upon the network address
>    of the client that initiated the query rather than of the client's
>    Recursive Resolver.
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-vandergaast-edns-client-ip-00.txt

---

From: "Martin Stiemerling" <[email-masked]>
Date: Fri, 29 Jan 2010 21:47:01 +0100

Enrico,

Isn't this more about localizing the client instead of load-balancing in the first place?

  Martin

[email-masked]

NEC Laboratories Europe - Network Research Division
NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Enrico Marocco
> Sent: Friday, January 29, 2010 12:14 PM
> To: [email-masked]
> Subject: [alto] [Fwd: [dnsext] Re: I-DACTION:draft-vandergaast-edns-
> client-ip-00.txt]
>