Subject: Re: [Idr] Re: draft-ietf-idr-as-pathlimit-03.txt

From: Marcelo Schmidt <[email-masked]>
Date: Tue, 14 Aug 2007 11:41:02 -0700

On Mon, Jul 30, 2007 at 07:11:59AM -0700, Tony Li wrote:
>    >    E.g. When sending an AS_PATHLIMIT with a private-ASN to an EBGP
>    >    neighbour outside of the parent AS, a speaker should update the
>    >    ASN in the attribute with preferrably its own ASN, if that is a
>    >    public ASN, or else the ASN of the EBGP peer the attribute is
>    >    being sent to, if that is a public ASN.
>    >
>    >  That still allows for the discretion around determining 'parent AS'
>    > which the original wording carefully put there, but gives a gentle
>    > hint as to expected behaviour..
> 
>    Works for me.  Other folks?

I think the e.g works but I just have a little problem understand the
wording around the end of the e.g. "being sent to, if that is a public ASN."
If I would tried to follow the example in this kinda psuedo C (laughable
enough) it looks like this :)

/* AS_PATHLIMIT with a private-ASN to an EBGP \
_neighbor_ outside of the parent AS: */
	
	if (that is a public ASN) {
		a speaker should update the ASN in  \
		the attribute with preferrably its own ASN
	} else { 
		the ASN of the EBGP peer the attribute is \
		being sent to
	}
	if that is a public ASN?

-- 
-m

====================================================================
Key fingerprint = 8E48 6CD0 6D2B 538E 264B  D1D0 21E2 E7EE A40F 2A0B
gpg --keyserver wwwkeys.pgp.net --recv-keys 0xA40F2A0B
====================================================================

_______________________________________________
Idr mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/idr

---

From: Tony Li <[email-masked]>
Date: Tue, 14 Aug 2007 14:17:35 -0700

> 		the ASN of the EBGP peer the attribute is \

Hi Marcelo,

I think you have the intent correct.  I might have coded it slightly  
differently.  ;-)

Tony