Subject: [Lager] [lager] #17 (specification): Text and example nitpick in 5.3.4

From: "lager issue tracker" <[email-masked]>
Date: Wed, 26 Aug 2015 21:25:50 -0000

#17: Text and example nitpick in 5.3.4

 In section 5.3.4:
 {{{
    To reference a named rule or class inside a rule or match operator
    use a rule or "class" element with an optional "by-ref" attribute
    containing the name of the referenced element.
 }}}

 misses quoting for rule element:

 {{{
    To reference a named rule or class inside a rule or match operator
    use a "rule" or "class" element with an optional "by-ref" attribute
    containing the name of the referenced element.
 }}}

 The example in the following paragraph is invalid:
 {{{
        <class name="letter" property="gc:L"/>
        <class name="combining-mark" property="gc:M"/>
        <class name="digit" property="gc:Nd">
        <rule name="letter-grapheme">
           <class by-ref="letter" count="1+"/>
           <class by-ref="combining-mark" count="0+"/>
        </rule>
 }}}

 The last class definition has no ending '/':
 {{{
 <class name="digit" property="gc:Nd"/>
 }}}

-- 
-------------------------------------+-------------------------------------
 Reporter:                           |      Owner:  draft-ietf-lager-
  [email-masked]    |  [email-masked]
     Type:  enhancement              |     Status:  new
 Priority:  trivial                  |  Milestone:
Component:  specification            |    Version:
 Severity:  -                        |   Keywords:
-------------------------------------+-------------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/lager/trac/ticket/17>
lager <http://tools.ietf.org/lager/>

---

From: Asmus Freytag <[email-masked]>
Date: Wed, 26 Aug 2015 17:13:31 -0700

Good catches, I'll fix those for the -01 draft.

A./