Subject: [Lager] Default Namespace

From: "Hollenbeck, Scott" <[email-masked]>
Date: Tue, 22 Sep 2015 12:06:50 +0000

From: Lager [mailto:[email-masked]] On Behalf Of Asmus Freytag
Sent: Monday, September 21, 2015 4:03 PM
To: [email-masked]
Subject: [Lager] Fwd: I-D Action: draft-ietf-lager-specification-03.txt

I've rolled up the pending discussion into an -03 draft. People should verify that this addresses their concerns.

At this point, it would be useful for someone more experienced with schemas to check the schema for the <scope> element.

I just did some basic XML validation checking. One nit: the default namespace used in the schema found in Appendix D is http://www.iana.org/lgr/0.1. The namespace used in the examples included in Appendix A is “urn:ietf:params:xml:ns:lgr-1.0”. These should be consistent with the latter type being more commonly used. Both of the examples appear to be otherwise valid per the schema.

Scott

---

From: Asmus Freytag <[email-masked]>
Date: Tue, 22 Sep 2015 11:15:15 -0700

On 9/22/2015 5:06 AM, Hollenbeck, Scott wrote:
>
> *From:*Lager [mailto:[email-masked]] *On Behalf Of *Asmus Freytag
> *Sent:* Monday, September 21, 2015 4:03 PM
> *To:* [email-masked]
> *Subject:* [Lager] Fwd: I-D Action: draft-ietf-lager-specification-03.txt
>
> I've rolled up the pending discussion into an -03 draft. People should 
> verify that this addresses their concerns.
>
> At this point, it would be useful for someone more experienced with 
> schemas to check the schema for the <scope> element.
>
> I just did some basic XML validation checking. One nit: the default 
> namespace used in the schema found in Appendix D is 
> http://www.iana.org/lgr/0.1. The namespace used in the examples 
> included in Appendix A is “urn:ietf:params:xml:ns:lgr-1.0”. These 
> should be consistent with the latter type being more commonly used. 
> Both of the examples appear to be otherwise valid per the schema.
>

Scott,

can you phrase this more explicitly like "change x to y in paragraph z"

Because I can't make heads or tails of your comment.

A./
>
> Scott
>
>
>
> _______________________________________________
> Lager mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lager

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Tue, 22 Sep 2015 19:14:45 +0000

You need to pick one of those namespace identifiers and use it consistently throughout the document. I suggest changing “http://www.iana.org/lgr/0.1” to “urn:ietf:params:xml:ns:lgr-1.0” in the schema.

Scott

From: Lager [mailto:[email-masked]] On Behalf Of Asmus Freytag
Sent: Tuesday, September 22, 2015 2:15 PM
To: [email-masked]
Subject: Re: [Lager] Default Namespace

To: [email-masked]<mailto:[email-masked]>

Scott,

A./

Scott

Lager mailing list

[email-masked]<mailto:[email-masked]>

---

From: "Marc Blanchet" <[email-masked]>
Date: Tue, 22 Sep 2015 15:18:47 -0400

On 22 Sep 2015, at 15:14, Hollenbeck, Scott wrote:

> You need to pick one of those namespace identifiers and use it 
> consistently throughout the document. I suggest changing 
> “http://www.iana.org/lgr/0.1” to 
> “urn:ietf:params:xml:ns:lgr-1.0” in the schema.

+1. Marc.

---

From: Asmus Freytag <[email-masked]>
Date: Tue, 22 Sep 2015 12:25:52 -0700

On 9/22/2015 12:18 PM, Marc Blanchet wrote:
>> “http://www.iana.org/lgr/0.1” to “urn:ietf:params:xml:ns:lgr-1.0” in 
>> the schema.
>
> +1. Marc.

OK.

Thanks,

A./

PS: the <scope> element in the schema looks incorrect to me (use of 
attributes?). Can you let me know if changes are needed?
>> I've rolled up the pending discussion into an -03 draft. People 
>> should verify that this addresses their concerns.
>>