Subject: [Lager] Comments to XML-Draft

From: "Z.W. Yan" <[email-masked]>
Date: Tue, 15 Sep 2015 14:12:14 +0800

Hi, all,
This is Zhiwei Yan, from CNNIC and member of CGP.
About the XML draft, I have the following comments and question:
1) the type "out-of-repertoire-var" was introduced in the 10-version. In the revision of Yoneya-san's algorithm, IP suggested that this type should be only used for the reflexive case. 
I think it's better to give clear definition and usage policy of it.
2) there is a inconsistency of "any-variants" in the whole content and "any-variant" in subsection 6.2.1.
3) in  Appendix B, there are two types of "<action>" in the rules: <action disp="block"     any-variant="simp trad" /> and <action disp="block" all-variants="simp trad both" />, what the actual difference between them？
BR,
Zhiwei 

2015-09-15

---

From: Asmus Freytag <[email-masked]>
Date: Wed, 16 Sep 2015 02:12:12 -0700

> I think it's better to give clear definition and usage policy of it.

Good comment
> 2) there is a inconsistency of "any-variants" in the whole content and "any-variant" in subsection 6.2.1.

That should be fixed in the -02 version of the draft

> 3) in  Appendix B, there are two types of "<action>" in the rules: <action disp="block"     any- 
> variant="simp trad" /> and <action disp="block" all- 
> variants="simp trad both" /& 
> gt;, what the actual difference between them？

The first one doesn't get triggered by any label that has, for example, 
only variants of type "both". It would get triggered by a label 
containing either simp or trad  variants (or both of these two types) 
together with any other type.

The second action would not get triggered if there was any variant of 
type other than simp, trad or both.

Both actions allow code points that have no variant mappings to be 
present in the label.

A./

> BR,
> Zhiwei
> 2015-09-15
>
>
> _______________________________________________
> Lager mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lager