Subject: [Lager] [Errata Verified] RFC7940 (5986)

From: RFC Errata System <[email-masked]>
Date: Sat, 22 Feb 2020 10:43:45 -0800 (PST)

The following errata report has been verified for RFC7940,
"Representing Label Generation Rulesets Using XML". 

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid5986

--------------------------------------
Status: Verified
Type: Technical

Reported by: KIM Kyongsok <[email-masked]>
Date Reported: 2020-02-22
Verified by: Barry Leiba (IESG)

Section: 6.3.1

Original Text
-------------
   A simple rule to match a label where all characters are members of
   some class called "preferred-codepoint":          

       <rule name="preferred-label">
           <start />
           <class by-ref="preferred-codepoint" count="1"/>
           <end />
       </rule>

Corrected Text
--------------
   A simple rule to match a label where all characters are members of
   some class called "preferred-codepoint":           

       <rule name="preferred-label">
           <start />
           <class by-ref="preferred-codepoint" count="1+"/>
           <end />
       </rule>

Notes
-----
Currently the value for count is 1, which means that the rule will match a label composed of only one char.
However, since the rule is supposed to match a label composed one or more chars, the value ofr count must be "1+" .

--------------------------------------
RFC7940 (draft-ietf-lager-specification-13)
--------------------------------------
Title               : Representing Label Generation Rulesets Using XML
Publication Date    : August 2016
Author(s)           : K. Davies, A. Freytag
Category            : PROPOSED STANDARD
Source              : Label Generation Rules
Area                : Applications and Real-Time
Stream              : IETF
Verifying Party     : IESG

---

From: Asmus Freytag <[email-masked]>
Date: Sat, 22 Feb 2020 08:05:59 -0800

Correct, it needs to be "1+" not "1".

On 2/21/2020 7:40 PM, RFC Errata System wrote:
> The following errata report has been submitted for RFC7940,
> Am I missing something here?
>
> Thanks.
>
> Instructions:
> -------------
> This erratum is currently posted as "Reported". If necessary, please
> use "Reply All" to discuss whether it should be verified or
> rejected. When a decision is reached, the verifying party
> can log in to change the status and edit the report, if necessary.
>