Subject: RE: [Manet-dt] Proposed New Dymo Text - Judging Information Usefulness

From: "Koojana Kuladinithi" <[email-masked]>
Date: Tue, 5 Sep 2006 14:26:37 +0200

Hi Ian

Text is bit confusing. 

In "5.Superior" says that " Routing information that does not match any
of the 
above criteria is loop-free and better than the information existing in
the routing table". That means reader thinks that you are considering
"1. Fresh" is also not used to update the routing table.

I don't see under any of those conditions, you have not addressed,
Node.HopCnt > Route.HopCnt when Node.SeqNum == Route.SeqNum as Loop
probable. This case is different from Node.HopCnt > Route.HopCnt + 1

Kind regards

koojana 

> -----Original Message-----
> From: Ian Chakeres [mailto:[email-masked]] 
> Sent: 28 August 2006 18:02
> To: [email-masked]
> Subject: [Manet-dt] Proposed New Dymo Text - Judging 
> Information Usefulness
> 
> 
> Please let me know what you think of this text.
> 
> Ian
> 
> Note: that broken is kind of like invalid. I'm still 
> experimenting with the term.
> 
> 5.2.1.  Judging Routing Information's Usefulness
> 
>    Given a routing table entry (Route.SeqNum, Route.HopCnt, and
>    Route.Broken) and new routing information for a particular 
> node in a
>    RM (Node.SeqNum, Node.HopCnt, and RM message type - RREQ/RREP), the
>    quality of the new routing information is evaluated to 
> determine its
>    usefulness.  The following comparisons are performed in order:
> 
>    1. Fresh
>       If Node.SeqNum - Route.SeqNum > 0 (using signed 16-bit 
> arithmetic)
>       the information is fresh.  This information is newer than that
>       known and should be used to update the routing table.
> 
>    2. Stale
>       If Node.SeqNum - Route.SeqNum < 0 (using signed 16-bit 
> arithmetic)
>       the information is stale.  Using stale routing 
> information is not
>       allowed, since doing so might result in routing loops.
> 
>    3. Loop-possible
>       If Node.SeqNum == Route.SeqNum the information may 
> cause loops if
>       used, in this case additional information must be examined.  If
>       Route.HopCnt is unknown or set to zero (0), then the routing
>       information is loop-possible.  Likewise, if Node.HopCnt 
> is unknown
>       or set to zero (0), then the routing information is 
> loop-possible.
>       If Node.HopCnt > Route.HopCnt + 1, then the routing 
> information is
>       loop-possible.  Using loop-possible routing information is not
>       allowed, since doing so might result in routing loops.
> 
>    4. Inferior
>       If Node.SeqNum == Route.SeqNum the information may be inferior,
>       additional information must be examined.  If the Node.HopCnt ==
>       Route.HopCnt + 1 or Route.HopCnt, the current route is 
> not Broken
>       and the message is a RREQ, then the new information is inferior.
>       Inferior routes will not cause routing loops if introduced, but
>       should not be used since better information is already 
> available.
> 
>    5. Superior
>       Routing information that does not match any of the 
> above criteria
>       is loop-free and better than the information existing in the
>       routing table.  This type of information is used to update the
>       routing table.  For completeness, the following other cases are
>       possible:
> 
>          Node.HopCnt == Route.HopCnt + 1 or Route.HopCnt and the route
>          is Broken.
> 
>          Node.HopCnt == Route.HopCnt + 1 or Route.HopCnt and the route
>          is not Broken and the message is a RREP,
> 
>          Node.HopCnt < Route.HopCnt.
> 
> _______________________________________________
> Manet-dt mailing list
> [email-masked] https://www1.ietf.org/mailman/listinfo/manet-dt
> 

_______________________________________________
Manet-dt mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet-dt

---

From: "Koojana Kuladinithi" <[email-masked]>
Date: Tue, 5 Sep 2006 16:20:16 +0200

Hi Ian
Sorry, I misunderstood something. You have adrresed the last issue that
I pointed under "Inferior" case

Koojana

> From: Koojana Kuladinithi [mailto:[email-masked]] 
> Sent: 05 September 2006 14:27
> To: 'Ian Chakeres'; [email-masked]'
> Subject: RE: [Manet-dt] Proposed New Dymo Text - Judging 
> Information Usefulness
> 
> 
> Hi Ian
> 
> Text is bit confusing. 
> 
> 
> In "5.Superior" says that " Routing information that does not 
> match any of the 
> above criteria is loop-free and better than the information 
> existing in the routing table". That means reader thinks that 
> you are considering "1. Fresh" is also not used to update the 
> routing table.
> 
> I don't see under any of those conditions, you have not 
> addressed, Node.HopCnt > Route.HopCnt when Node.SeqNum == 
> Route.SeqNum as Loop probable. This case is different from 
> Node.HopCnt > Route.HopCnt + 1
> 
> Kind regards
> 
> koojana 
>  
>