Subject: [Modern] Alissa Cooper's Yes on charter-ietf-modern-00-02: (with COMMENT)

From: "Alissa Cooper" <[email-masked]>
Date: Tue, 09 Jun 2015 16:09:52 -0700

Alissa Cooper has entered the following ballot position for
charter-ietf-modern-00-02: Yes

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/charter-ietf-modern/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Since I was on leave and Ben was shepherding this work until very
recently, I did not have a chance to provide comments on the charter
until now. I think overall the charter is good but I have a bunch of
suggestions to make it crisper and more understandable for people who are
new to this work. In the edit below I've tried to remove some of the
redundant language. I edited the first paragraph and removed the example
problems, which included a lot of domain-specific terms that were not
properly explained and didn't add much overall. I added STIR to the list
of other relevant IETF WGs. The substance of the charter hasn't changed,
but I'd like the folks on the mailing list to review the changes before I
put them into the tracker.

--

The MODERN working group will define a set of Internet-based mechanisms
for the purposes of managing and resolving telephone numbers (TNs) in an
IP environment. Existing mechanisms for these purposes face obsolescence
as the voice communications infrastructure evolves to IP technology and
new applications for TNs become possible. The traditional model of a TN
having an association to a single service provider and a single
application is breaking down. Its use as a network locator is going away,
but its use as an identifier for an individual or an organization will
remain for some time. Devices, applications, and network tools
increasingly need to manage TNs, including requesting and acquiring TN
delegations from authorities. The output of the working group should make
distribution, acquisition, and management of TNs simpler for all entities
involved.

The working group will define an information management framework for the
roles and functions involved in associating information with one or more
TNs in an IP environment.  The working group will also identify protocol
mechanisms to support the interactions between the functions defined by
the framework. This includes either recommending or defining protocol
mechanisms for acquiring, associating and resolving TNs, with a
preference for use of existing protocol mechanisms. TNs may either be
managed in a hierarchical tree, or in a distributed registry. The
protocol mechanism for acquiring TNs will provide an enrollment process
for the entities that use and manage TNs. 

The protocol mechanism for resolving TNs will allow entities such as
service providers, devices, and applications to access data related to
TNs. Maintaining reliability, real-time application performance, and
security and privacy for both the data and the protocol interactions are
primary considerations. The working group will take into consideration
existing IETF work including STIR, ENUM, SPEERMINT, DRINKS and SCIM.

The work of this group will focus on TNs, as defined in RFC3966, and
blocks of TNs, that are used to initiate communication with another user
of a service. There is an expectation that aspects of the architecture
and protocols defined by the working group will be reusable for other
user-focused identifiers. Any such extensions or reuse of MODERN
mechanisms are out of scope for the MODERN working group. Solutions and
mechanisms created by the working group will be flexible enough to
accommodate different policies for TN assignment and management, for
example those established by different regulatory agencies.

The working group will deliver the following:

- An architecture overview, including high level requirements and
security/privacy considerations

- A description of the enrollment processes for existing and new TNs
including any modifications to metadata related to those TNs

- A description of protocol mechanisms for accessing contact information
associated with enrollments

- A description of mechanisms for resolving information related to TNs

---

From: Steve Donovan <[email-masked]>
Date: Wed, 10 Jun 2015 10:25:48 -0500

Alissa,

The changes look good to me.

Steve

On 6/9/15 6:09 PM, Alissa Cooper wrote:
> _______________________________________________
> Modern mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/modern
>

---

From: "Castagna, James T (Jim)" <[email-masked]>
Date: Wed, 10 Jun 2015 11:32:52 -0400

Now that the charter is nearly finalized it becomes more evident that the second and third sentences in the first paragraph don't belong in a charter.  I don't believe the IETF needs to substantiate their interest in developing new tools and eliminating these sentences will avoid the misinterpretation that these issues are the only reasons why the IETF is taking on this work.  

See how it reads without these sentences:

--

MODERN (2 / 3 paragraph deleted)

The MODERN working group will define a set of Internet-based mechanisms for the purposes of managing and resolving telephone numbers (TNs) in an IP environment. Devices, applications, and network tools increasingly need to manage TNs, including requesting and acquiring TN delegations from authorities. The output of the working group should make distribution, acquisition, and management of TNs simpler for all entities involved.

The working group will define an information management framework for the roles and functions involved in associating information with one or more TNs in an IP environment.  The working group will also identify protocol mechanisms to support the interactions between the functions defined by the framework. This includes either recommending or defining protocol mechanisms for acquiring, associating and resolving TNs, with a preference for use of existing protocol mechanisms. TNs may either be managed in a hierarchical tree, or in a distributed registry. The protocol mechanism for acquiring TNs will provide an enrollment process for the entities that use and manage TNs. 

The protocol mechanism for resolving TNs will allow entities such as service providers, devices, and applications to access data related to TNs. Maintaining reliability, real-time application performance, and security and privacy for both the data and the protocol interactions are primary considerations. The working group will take into consideration existing IETF work including STIR, ENUM, SPEERMINT, DRINKS and SCIM.

The work of this group will focus on TNs, as defined in RFC3966, and blocks of TNs, that are used to initiate communication with another user of a service. There is an expectation that aspects of the architecture and protocols defined by the working group will be reusable for other user-focused identifiers. Any such extensions or reuse of MODERN mechanisms are out of scope for the MODERN working group. Solutions and mechanisms created by the working group will be flexible enough to accommodate different policies for TN assignment and management, for example those established by different regulatory agencies.

- An architecture overview, including high level requirements and security/privacy considerations

- A description of the enrollment processes for existing and new TNs including any modifications to metadata related to those TNs

- A description of protocol mechanisms for accessing contact information associated with enrollments

-----Original Message-----
From: Modern [mailto:[email-masked]] On Behalf Of Steve Donovan
Sent: Wednesday, June 10, 2015 11:26 AM
To: Alissa Cooper; The IESG
Cc: [email-masked]; [email-masked]; Tom McGarry
Subject: Re: [Modern] Alissa Cooper's Yes on charter-ietf-modern-00-02: (with COMMENT)

  Alissa,

Steve

On 6/9/15 6:09 PM, Alissa Cooper wrote:
> email addresses included in the To and CC lines. (Feel free to cut 
> this introductory paragraph, however.)
>
>
>
> suggestions to make it crisper and more understandable for people who 
> are new to this work. In the edit below I've tried to remove some of 
> the redundant language. I edited the first paragraph and removed the 
> example problems, which included a lot of domain-specific terms that 
> were not properly explained and didn't add much overall. I added STIR 
> to the list of other relevant IETF WGs. The substance of the charter 
> hasn't changed, but I'd like the folks on the mailing list to review 
> the changes before I put them into the tracker.
>
> --
>
> The MODERN working group will define a set of Internet-based 
> mechanisms for the purposes of managing and resolving telephone 
> numbers (TNs) in an IP environment. Existing mechanisms for these 
> purposes face obsolescence as the voice communications infrastructure 
> evolves to IP technology and new applications for TNs become possible. 
> The traditional model of a TN having an association to a single 
> service provider and a single application is breaking down. Its use as 
> a network locator is going away, but its use as an identifier for an 
> individual or an organization will remain for some time. Devices, 
> applications, and network tools increasingly need to manage TNs, 
> including requesting and acquiring TN delegations from authorities. 
> The output of the working group should make distribution, acquisition, 
> and management of TNs simpler for all entities involved.
>
> The working group will define an information management framework for 
> the roles and functions involved in associating information with one 
> or more TNs in an IP environment.  The working group will also 
> identify protocol mechanisms to support the interactions between the 
> functions defined by the framework. This includes either recommending 
> or defining protocol mechanisms for acquiring, associating and 
> resolving TNs, with a preference for use of existing protocol 
> mechanisms. TNs may either be managed in a hierarchical tree, or in a 
> distributed registry. The protocol mechanism for acquiring TNs will 
> provide an enrollment process for the entities that use and manage TNs.
>
> security and privacy for both the data and the protocol interactions 
> are primary considerations. The working group will take into 
> consideration existing IETF work including STIR, ENUM, SPEERMINT, DRINKS and SCIM.
>
> blocks of TNs, that are used to initiate communication with another 
> user of a service. There is an expectation that aspects of the 
> architecture and protocols defined by the working group will be 
> reusable for other user-focused identifiers. Any such extensions or 
> reuse of MODERN mechanisms are out of scope for the MODERN working 
> group. Solutions and mechanisms created by the working group will be 
> flexible enough to accommodate different policies for TN assignment 
> and management, for example those established by different regulatory agencies.
>
> - A description of protocol mechanisms for accessing contact 
> information associated with enrollments
>

---

From: "Gorman, Pierce A [CTO]" <[email-masked]>
Date: Wed, 10 Jun 2015 22:13:20 +0000

I think you meant 2nd, 3rd, and 4th sentences don't belong in the charter.  At least, that's what you deleted.  (See highlighted deleted sentences below.)

Best regards,

Pierce Gorman

Core Network Planning

O: 913-439-4368

[email-masked]

-----Original Message-----
From: Modern [mailto:[email-masked]] On Behalf Of Castagna, James T (Jim)
Sent: June 10, 2015 10:33 AM
To: Steve Donovan; Alissa Cooper; The IESG
Cc: [email-masked]; [email-masked]; Tom McGarry
Subject: Re: [Modern] Alissa Cooper's Yes on charter-ietf-modern-00-02: (with COMMENT)

COMMENT:

--

-----Original Message-----

Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Tom McGarry

  Alissa,

Steve

> [email-masked]<mailto:[email-masked]>

Modern mailing list

[email-masked]<mailto:[email-masked]>

Modern mailing list

[email-masked]<mailto:[email-masked]>

________________________________

This e-mail may contain Sprint proprietary information intended for the sole use of the recipient(s). Any use by others is prohibited. If you are not the intended recipient, please contact the sender and delete all copies of the message.

---

From: "Gorman, Pierce A [CTO]" <[email-masked]>
Date: Wed, 10 Jun 2015 22:15:25 +0000

I should also mention Sprint agrees with the suggested changes from Jim.

Best regards,

Pierce Gorman
Core Network Planning
O: 913-439-4368
[email-masked]

From: Modern [mailto:[email-masked]] On Behalf Of Gorman, Pierce A [CTO]
Sent: June 10, 2015 5:13 PM
To: Castagna, James T (Jim); Steve Donovan; Alissa Cooper; The IESG
Cc: [email-masked]; [email-masked]; Tom McGarry
Subject: Re: [Modern] Alissa Cooper's Yes on charter-ietf-modern-00-02: (with COMMENT)

Best regards,

Pierce Gorman

Core Network Planning

O: 913-439-4368

[email-masked]<mailto:[email-masked]>

-----Original Message-----
From: Modern [mailto:[email-masked]] On Behalf Of Castagna, James T (Jim)
Sent: June 10, 2015 10:33 AM
To: Steve Donovan; Alissa Cooper; The IESG
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Tom McGarry
Subject: Re: [Modern] Alissa Cooper's Yes on charter-ietf-modern-00-02: (with COMMENT)

COMMENT:

--

-----Original Message-----

  Alissa,

Steve

Modern mailing list

Modern mailing list

---

From: "Castagna, James T (Jim)" <[email-masked]>
Date: Wed, 10 Jun 2015 18:36:39 -0400

My error, thank you.

From: Gorman, Pierce A [CTO] [mailto:[email-masked]]
Sent: Wednesday, June 10, 2015 6:15 PM
To: Castagna, James T (Jim); Steve Donovan; Alissa Cooper; The IESG
Cc: [email-masked]; [email-masked]; Tom McGarry
Subject: RE: [Modern] Alissa Cooper's Yes on charter-ietf-modern-00-02: (with COMMENT)

Best regards,

Pierce Gorman
Core Network Planning
O: 913-439-4368

Best regards,

Pierce Gorman

Core Network Planning

O: 913-439-4368

-----Original Message-----
From: Modern [mailto:[email-masked]] On Behalf Of Castagna, James T (Jim)
Sent: June 10, 2015 10:33 AM
To: Steve Donovan; Alissa Cooper; The IESG
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Tom McGarry
Subject: Re: [Modern] Alissa Cooper's Yes on charter-ietf-modern-00-02: (with COMMENT)

COMMENT:

--

-----Original Message-----

  Alissa,

Steve

Modern mailing list

Modern mailing list

---

From: Richard Shockey <[email-masked]>
Date: Wed, 10 Jun 2015 22:49:50 -0400

As do I. 

‹ 
Richard Shockey
Shockey Consulting LLC
Chairman of the Board SIP Forum
www.shockey.us
www.sipforum.org
richard<at>shockey.us
Skype-Linkedin-Facebook rshockey101
PSTN +1 703-593-2683

From:  "[email-masked]" <[email-masked]>
Date:  Wednesday, June 10, 2015 at 6:15 PM
To:  James Castagna <[email-masked]>, Steve Donovan
<[email-masked]>, Alissa Cooper <[email-masked]>, The IESG
<[email-masked]>
Cc:  Ben Campbell <[email-masked]>, "[email-masked]" <[email-masked]>,
Tom McGarry <[email-masked]>
Subject:  Re: [Modern] Alissa Cooper's Yes on charter-ietf-modern-00-02:
(with COMMENT)

Best regards,

Pierce Gorman
Core Network Planning
O: 913-439-4368
[email-masked]

From: Modern [mailto:[email-masked]] On Behalf Of Gorman, Pierce A
[CTO]
Sent: June 10, 2015 5:13 PM
To: Castagna, James T (Jim); Steve Donovan; Alissa Cooper; The IESG
Cc: [email-masked]; [email-masked]; Tom McGarry
Subject: Re: [Modern] Alissa Cooper's Yes on charter-ietf-modern-00-02:
(with COMMENT)
 
I think you meant 2nd, 3rd, and 4th sentences don't belong in the charter.
At least, that's what you deleted.  (See highlighted deleted sentences
below.)
 
Best regards,

Pierce Gorman
Core Network Planning
O: 913-439-4368
[email-masked]

-----Original Message-----
From: Modern [mailto:[email-masked]] On Behalf Of Castagna, James T
(Jim)
Sent: June 10, 2015 10:33 AM
To: Steve Donovan; Alissa Cooper; The IESG
Cc: [email-masked]; [email-masked]; Tom McGarry
Subject: Re: [Modern] Alissa Cooper's Yes on charter-ietf-modern-00-02:
(with COMMENT)

Now that the charter is nearly finalized it becomes more evident that the
second and third sentences in the first paragraph don't belong in a charter.
I don't believe the IETF needs to substantiate their interest in developing
new tools and eliminating these sentences will avoid the misinterpretation
that these issues are the only reasons why the IETF is taking on this work.

--

The MODERN working group will define a set of Internet-based mechanisms for
the purposes of managing and resolving telephone numbers (TNs) in an IP
environment. Devices, applications, and network tools increasingly need to
manage TNs, including requesting and acquiring TN delegations from
authorities. The output of the working group should make distribution,
acquisition, and management of TNs simpler for all entities involved.
 
The working group will define an information management framework for the
roles and functions involved in associating information with one or more TNs
in an IP environment.  The working group will also identify protocol
mechanisms to support the interactions between the functions defined by the
framework. This includes either recommending or defining protocol mechanisms
for acquiring, associating and resolving TNs, with a preference for use of
existing protocol mechanisms. TNs may either be managed in a hierarchical
tree, or in a distributed registry. The protocol mechanism for acquiring TNs
will provide an enrollment process for the entities that use and manage TNs.
 
The protocol mechanism for resolving TNs will allow entities such as service
providers, devices, and applications to access data related to TNs.
Maintaining reliability, real-time application performance, and security and
privacy for both the data and the protocol interactions are primary
considerations. The working group will take into consideration existing IETF
work including STIR, ENUM, SPEERMINT, DRINKS and SCIM.
 
The work of this group will focus on TNs, as defined in RFC3966, and blocks
of TNs, that are used to initiate communication with another user of a
service. There is an expectation that aspects of the architecture and
protocols defined by the working group will be reusable for other
user-focused identifiers. Any such extensions or reuse of MODERN mechanisms
are out of scope for the MODERN working group. Solutions and mechanisms
created by the working group will be flexible enough to accommodate
different policies for TN assignment and management, for example those
established by different regulatory agencies.

 

 
-----Original Message-----
From: Modern [mailto:[email-masked]
<mailto:[email-masked]> ] On Behalf Of Steve Donovan
Sent: Wednesday, June 10, 2015 11:26 AM
To: Alissa Cooper; The IESG
Cc: [email-masked] <mailto:[email-masked]> ; [email-masked]
<mailto:[email-masked]> ; Tom McGarry
Subject: Re: [Modern] Alissa Cooper's Yes on charter-ietf-modern-00-02:
(with COMMENT)
 
  Alissa,

Steve
 
> https://datatracker.ietf.org/doc/charter-ietf-modern/
<https://datatracker.ietf.org/doc/charter-ietf-modern/>
> service provider and a single application is breaking down.Its use as
> [email-masked] <mailto:[email-masked]>
<https://www.ietf.org/mailman/listinfo/modern>
 
_______________________________________________
Modern mailing list
[email-masked] <mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/modern
<https://www.ietf.org/mailman/listinfo/modern>
 
_______________________________________________
Modern mailing list
[email-masked] <mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/modern
<https://www.ietf.org/mailman/listinfo/modern>

This e-mail may contain Sprint proprietary information intended for the sole
use of the recipient(s). Any use by others is prohibited. If you are not the
intended recipient, please contact the sender and delete all copies of the
message.

This e-mail may contain Sprint proprietary information intended for the sole
use of the recipient(s). Any use by others is prohibited. If you are not the
intended recipient, please contact the sender and delete all copies of the
message.
_______________________________________________ Modern mailing list
[email-masked] https://www.ietf.org/mailman/listinfo/modern

---

From: Alissa Cooper <[email-masked]>
Date: Thu, 11 Jun 2015 09:24:05 -0700

I think the the charter would be fine with or without the sentences in question, so if people prefer to remove them that seems okay. I don’t think these changes affect the scope of the group’s work.

I’ll post the below version of the charter text to the tracker on Friday and it will go out for external review then unless other folks on the list object.

Alissa