Subject: [ncrg] Document structure - mindmap

From: "Michael Behringer (mbehring)" <[email-masked]>
Date: Tue, 25 Jun 2013 13:59:10 +0000

Finally I found some structure that makes sense in my head - I send it here so that everyone can look at it on the call in a few minutes. I hope many of you can attend. URL is https://cisco.webex.com/cisco/j.php?J=206990622&PW=NNDg4MzA0Nzlm

See you in 2 minutes! :)

Michael

---

From: David Meyer <[email-masked]>
Date: Tue, 25 Jun 2013 08:56:04 -0700

On Tue, Jun 25, 2013 at 8:55 AM, David Meyer <[email-masked]> wrote:
> A few comments from today:
>
> (i).  You can think of many (all?) system properties as types of
> robustness. For example:
>       * Reliability is robustness to component failures
>       • Eﬃciency is robustness to resource       carcity

Eﬃciency is robustness to resource scarcity. Don't know what happened
to that text.

--dmm

>       • Scalability is robustness to changes to the size and
> complexity of the system as a whole
>      • Modularity is robustness to structure component rearrangements
>      • Evolvability is robustness of lineages to changes on long time scales
>
> ...
>
> (ii). I also mentioned that these systems (organized complex systems)
> have 4 basic kinds of constraints:
>
> – component
> – system/environment
> – protocol
> – emergent
>
> I'll talk more about this in Berlin if we have time but briefly the
> components that comprise any system     are typically constrained in    terms
> of what they can do (component constraints). System constraints are
> about what the system should *do* (we talked about this in terms of
> "services"). Protocol constraints are constraints on how a system
> communicates with its environment. Finally, emergent constraints are
> nontrivial consequences of the interaction between the system and
> component-level constraints, and possibly protocols (if any). These
> fit into the outline but we might want to give examples.
>
> --dmm
>
>
> On Tue, Jun 25, 2013 at 8:26 AM, Luca Caviglione
> <[email-masked]> wrote:
>> Dear Michael and David,
>>
>> please find my comments as requested.
>>
>> 1) Try to produce a sort of "index" from the mindmap in order to find possible holes and gaps to be filled to have a readable document.
>>
>> 2) Users - how they interact. I do suggest to take into account (more explicitly) definition of service. Specifically, it should be helpful
>> to have some details on how users interact with network. However, providing a service to users can be
>> merged in robustness/scalability, as you suggested. Yet, it could be an interesting example showing whether users are (are not) isolated
>> from the network (e.g., a specific service requirement or change in the user population do not propagate on the whole system).
>>
>> 3) Agree on the changes made today in the mindmap.
>>
>> If you want, I can work on a section of the document, and see if it is inline with your views. Maybe I can try sketch some example
>> on optimization/constraints in a toy energy consumption use case, as to emphasize possible tradeoffs, or definitions needed in
>> the framework document.
>>
>> Thank you again for the meeting.
>>
>> Best Regards,
>> Luca
>>
>>
>>
>>
>> ==========================
>> Ing. Luca Caviglione, PhD
>> CNR - ISSIA (Genoa Branch)
>> http://users.ba.cnr.it/issia/iesilc78/
>> ==========================

---

From: David Meyer <[email-masked]>
Date: Tue, 25 Jun 2013 08:55:15 -0700

...

– component	
– system/environment	
– protocol	
– emergent

--dmm