Subject: Re: [Unbearable] Token binding version (0, 10) support is global on google servers

From: Nick Harper <[email-masked]>
Date: Thu, 23 Feb 2017 12:05:29 -0800

FYI:
We are updating Google servers to only support Token Binding version (0,
13).

On Fri, Jan 20, 2017 at 11:46 AM, Pranav Kukreja <[email-masked]>
wrote:

> Anupam, are those connections from Edge resulting in any connection errors
> post the TLS handshake, especially during false start. I am chasing down
> some interop issues with Edge talking to google servers with TB enabled at
> the moment. If you notice anything please let us know.
>
>
>
> Thanks!
>
> Pranav
>
>
>
> *From:* Unbearable [mailto:[email-masked]] *On Behalf Of *Vinod
> Anupam
> *Sent:* Friday, January 20, 2017 10:02 AM
> *To:* Bill Cox <[email-masked]>
> *Cc:* Tokbind WG <[email-masked]>; token-binding-team <
> [email-masked]>
> *Subject:* Re: [Unbearable] Token binding version (0, 10) support is
> global on google servers
>
>
>
>
>
>
>
> On Fri, Jan 20, 2017 at 4:29 AM, Bill Cox <[email-masked]> wrote:
>
> I'm seeing 5.7K token binding headers per second at the moment, about 5K/s
> sending both channel-ID and token binding (probably chrome), and about
> 700/s with just token binding (probably not chrome).
>
>
>
> Based on information in our logs, the requests with just token binding
> headers are primarily from Edge.
>
>
>
> cheers,
>
> -Anupam
>
>
>
>
>
> Bill
>
> --
> You received this message because you are subscribed to the Google Groups
> "token-binding-team" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to [email-masked].
> To post to this group, send email to [email-masked].
> To view this discussion on the web visit https://groups.google.com/a/
> google.com/d/msgid/token-binding-team/CAH9QtQHiMNKTWkExDduH%3DhuCzs%
> 3DyVW%2BE7YM3Wnoh0DoeYUe08A%40mail.gmail.com
> <https://groups.google.com/a/google.com/d/msgid/token-binding-team/CAH9QtQHiMNKTWkExDduH%3DhuCzs%3DyVW%2BE7YM3Wnoh0DoeYUe08A%40mail.gmail.com?utm_medium=email&utm_source=footer>
> .
>
>
>
> _______________________________________________
> Unbearable mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/unbearable
>
>

---

From: Pranav Kukreja <[email-masked]>
Date: Thu, 23 Feb 2017 20:22:23 +0000

+Andrei

Thanks for the heads up Nick. Current Microsoft is advertising 0.10, so we will track this update on our end.

From: Nick Harper [mailto:[email-masked]]
Sent: Thursday, February 23, 2017 12:05 PM
To: Pranav Kukreja <[email-masked]>
Cc: Vinod Anupam <[email-masked]>; Bill Cox <[email-masked]>; Tokbind WG <[email-masked]>; token-binding-team <[email-masked]>
Subject: Re: [Unbearable] Token binding version (0, 10) support is global on google servers

FYI:
We are updating Google servers to only support Token Binding version (0, 13).

On Fri, Jan 20, 2017 at 11:46 AM, Pranav Kukreja <[email-masked]<mailto:[email-masked]>> wrote:
Anupam, are those connections from Edge resulting in any connection errors post the TLS handshake, especially during false start. I am chasing down some interop issues with Edge talking to google servers with TB enabled at the moment. If you notice anything please let us know.

Thanks!
Pranav

From: Unbearable [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Vinod Anupam
Sent: Friday, January 20, 2017 10:02 AM
To: Bill Cox <[email-masked]<mailto:[email-masked]>>
Cc: Tokbind WG <[email-masked]<mailto:[email-masked]>>; token-binding-team <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Unbearable] Token binding version (0, 10) support is global on google servers

On Fri, Jan 20, 2017 at 4:29 AM, Bill Cox <[email-masked]<mailto:[email-masked]>> wrote:
I'm seeing 5.7K token binding headers per second at the moment, about 5K/s sending both channel-ID and token binding (probably chrome), and about 700/s with just token binding (probably not chrome).

Based on information in our logs, the requests with just token binding headers are primarily from Edge.

cheers,
-Anupam

Bill
--
You received this message because you are subscribed to the Google Groups "token-binding-team" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email-masked]<mailto:[email-masked]>.
To post to this group, send email to [email-masked]<mailto:[email-masked]>.
To view this discussion on the web visit https://groups.google.com/a/google.com/d/msgid/token-binding-team/CAH9QtQHiMNKTWkExDduH%3DhuCzs%3DyVW%2BE7YM3Wnoh0DoeYUe08A%40mail.gmail.com<https://groups.google.com/a/google.com/d/msgid/token-binding-team/CAH9QtQHiMNKTWkExDduH%3DhuCzs%3DyVW%2BE7YM3Wnoh0DoeYUe08A%40mail.gmail.com?utm_medium=email&utm_source=footer>.

_______________________________________________
Unbearable mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/unbearable

---

From: Hans Zandbelt <[email-masked]>
Date: Thu, 23 Feb 2017 21:58:48 +0100

FYI: I'm working on a module for Apache HTTPd here:
https://github.com/zmartzone/mod_token_binding

which relies on Google's token_bind library
https://github.com/google/token_bind

any chance that that library is going to be upgraded to (0, 13) as well?

Hans.

On Thu, Feb 23, 2017 at 9:05 PM, Nick Harper <[email-masked]> wrote:

>> Anupam, are those connections from Edge resulting in any connection
>> errors post the TLS handshake, especially during false start. I am chasing
>> down some interop issues with Edge talking to google servers with TB
>> enabled at the moment. If you notice anything please let us know.
>>
>>
>>
>> Thanks!
>>
>> Pranav
>>
>>
>>
>> I'm seeing 5.7K token binding headers per second at the moment, about
>> 5K/s sending both channel-ID and token binding (probably chrome), and about
>> To view this discussion on the web visit https://groups.google.com/a/go
>> ogle.com/d/msgid/token-binding-team/CAH9QtQHiMNKTWkExDduH%3DhuCzs%3DyVW%
>> 2BE7YM3Wnoh0DoeYUe08A%40mail.gmail.com

-- 
[email-masked]
ZmartZone IAM - www.zmartzone.eu

---

From: Bill Cox <[email-masked]>
Date: Thu, 23 Feb 2017 13:17:45 -0800

> any chance that that library is going to be upgraded to (0, 13) as well?

Yes, I'll do that now.  Note that Google servers will reject version (0,
10) going forward.  Hopefully this will be the last switch until version
(1, 0).

Bill

---

From: Bill Cox <[email-masked]>
Date: Thu, 23 Feb 2017 13:49:02 -0800

The library now supports version (0, 10) through (0, 13).  However Google's
front-end currently still supports only (0, 10), and when it switches, it
will switch to only (0, 13)

On Thu, Feb 23, 2017 at 1:17 PM, Bill Cox <[email-masked]> wrote:

> On Thu, Feb 23, 2017 at 12:58 PM, Hans Zandbelt <
> [email-masked]> wrote:
>