Subject: [siprec] I-D Action: draft-ietf-siprec-metadata-07.txt

From: [email-masked]
Date: Mon, 02 Jul 2012 23:03:24 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the SIP Recording Working Group of the IETF.

	Title           : Session Initiation Protocol (SIP) Recording Metadata
	Author(s)       : Ram Mohan Ravindranath
                          Parthasarathi Ravindran
                          Paul Kyzivat
	Filename        : draft-ietf-siprec-metadata-07.txt
	Pages           : 48
	Date            : 2012-07-02

Abstract:
   Session recording is a critical requirement in many communications
   environments such as call centers and financial trading.  In some of
   these environments, all calls must be recorded for regulatory,
   compliance, and consumer protection reasons.  Recording of a session
   is typically performed by sending a copy of a media stream to a
   recording device.  This document describes the metadata model as
   viewed by Session Recording Server(SRS) and the Recording metadata
   format.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-siprec-metadata

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-siprec-metadata-07

A diff from previous version is available at:
http://tools.ietf.org/rfcdiff?url2=draft-ietf-siprec-metadata-07

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Tue, 3 Jul 2012 06:17:05 +0000

Hi all,

This version of the draft tries the incorporate the comments received in
IETF 83
Refer to http://www.ietf.org/proceedings/83/minutes/minutes-83-siprec.pdf
for the minutes.

To summarize it has following changes:
1) Incorporated start/stop times for CS
2) Edits to CSRS association and ParticipantCSAssociation
3) Minor NITS received as comments in previous version
4) Modified the XML to have id as just id instead of group_id e.t.c and
session instead of session_id.
5) Modified the examples to reflect the change in schema in [4]

Please review the draft and provide your comments.

Authors

On 03/07/12 11:33 AM, "[email-masked]"
<[email-masked]> wrote:

>_______________________________________________
>siprec mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/siprec
>

---

From: "Hutton, Andrew" <[email-masked]>
Date: Mon, 9 Jul 2012 13:45:30 +0000

Hi All,

We need a few volunteers to do a full review of the SIPREC metadata draft.

If you are able to volunteer for this please let me know.

If we could have some people review the draft before IETF84 then that would be perfect.

Regards
Andy (SIPREC Co-Chair).

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Ram Mohan R (rmohanr)
> Sent: 03 July 2012 07:17
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: Re: [siprec] I-D Action: draft-ietf-siprec-metadata-07.txt
> 
> Hi all,
>

---

From: Michael Smith <[email-masked]>
Date: Mon, 9 Jul 2012 14:14:43 +0000

Andy,

I volunteer to do a review; is this the correct version: https://datatracker.ietf.org/doc/draft-ietf-siprec-metadata/ ?

Note: I'll limit my comments to basic editorial stuff, and things I'm pretty sure are real issues, since I've only recently become familiar with SIPREC and don't want to waste your time on things I simply don't understand. BTW, Brian Rosen knows me from NENA work. I'm on his LTD working group, and lead the NG9-1-1 PSAP working group, and the recording test committee. We've proposed using SIPREC as the media recording protocol in NG9-1-1.

Reviewing this draft will help me understand better, and hopefully provide some usable feedback to you.

Regards,

Michael Smith
Chief Technologist
Ph: 606.877.2788 | Mobile: 606.231.0243 

DSS Corporation / Equature
18311   W. Ten Mile Road, Suite 200
Southfield, MI - 48075
Tel: 1-888.305.3428
Fax: 1-248.569.6567
www.dss-corp.com
www.dispatchimprovement.com

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Hutton, Andrew
Sent: Monday, July 09, 2012 9:46 AM
To: [email-masked]
Subject: Re: [siprec] I-D Action: draft-ietf-siprec-metadata-07.txt

Hi All,

Regards
Andy (SIPREC Co-Chair).

> This version of the draft tries the incorporate the comments received 
> in IETF 83 Refer to 
> http://www.ietf.org/proceedings/83/minutes/minutes-83-
> siprec.pdf
> for the minutes.
> 
> 4) Modified the XML to have id as just id instead of group_id e.t.c 
> and session instead of session_id.

---

From: "Hutton, Andrew" <[email-masked]>
Date: Tue, 17 Jul 2012 12:44:51 +0000

Hi Michael,

Thanks for volunteering to review this draft and sorry it took so long for me to respond.

Yes the link you indicated below will point you at the right version.

It is great to know that NENA are interested in our work.

Any chance you will be in Vancouver for IETF84 or if not maybe you can join the session remotely?

Also it would be great to have your comments anytime but if you could make it before the IETF84 meeting then we could discuss any issues raised there.

Regards
Andy (SIPREC Co-Chair).

> Behalf Of Michael Smith
> Sent: 09 July 2012 15:15
> I volunteer to do a review; is this the correct version:
> https://datatracker.ietf.org/doc/draft-ietf-siprec-metadata/ ?
> 
> Note: I'll limit my comments to basic editorial stuff, and things I'm
> pretty sure are real issues, since I've only recently become familiar
> with SIPREC and don't want to waste your time on things I simply don't
> understand. BTW, Brian Rosen knows me from NENA work. I'm on his LTD
> working group, and lead the NG9-1-1 PSAP working group, and the
> recording test committee. We've proposed using SIPREC as the media
> recording protocol in NG9-1-1.
> 
> Behalf Of Hutton, Andrew

---

From: Michael Smith <[email-masked]>
Date: Mon, 23 Jul 2012 13:34:51 +0000

Andy,

I can't make the IETF meeting. I didn't know it was possible to join remotely, but I'd like to. Is the info for joining remotely on the IETF84 pages?

Michael Smith
Chief Technologist

-----Original Message-----
From: Hutton, Andrew [mailto:[email-masked]] 
Sent: Tuesday, July 17, 2012 8:45 AM
To: Michael Smith; [email-masked]
Subject: RE: [siprec] I-D Action: draft-ietf-siprec-metadata-07.txt

Hi Michael,

Regards
Andy (SIPREC Co-Chair).

> > This version of the draft tries the incorporate the comments 
> > received in IETF 83 Refer to
> > > This draft is a work item of the SIP Recording Working Group of 
> > >the
> > IETF.
> > >
> > >   environments such as call centers and financial trading.  In 
> > > some
> > of

---

From: Brian Rosen <[email-masked]>
Date: Mon, 23 Jul 2012 09:48:01 -0400

There are two ways to participate remotely.

One is the RTSP streaming service.  If you go to the tools meeting agenda:
http://tools.ietf.org/agenda/84/

you will find the link for the stream.  This is play only.

You then also join the jabber room, the link is on the same page.  To ask a question (or make an observation) you type "mic:" and your question/comment.  The designated jabber scribe will go to the floor microphone on your behalf.  The RSTP stream runs many seconds behind.

The other way is meetecho.  They will be supporting the siprec session.  You should be able to find the link on:
http://ietf84.conf.meetecho.com/

This is a real time multimedia streaming service with audio, video and text.

This is all detailed at:
http://www.ietf.org/meeting/84/remote-participation.html

Brian

---

From: Michael Smith <[email-masked]>
Date: Mon, 23 Jul 2012 13:49:21 +0000

Thanks, Brian - I'll do it!

Michael Smith
Chief Technologist

-----Original Message-----
From: Brian Rosen [mailto:[email-masked]] 
Sent: Monday, July 23, 2012 9:48 AM
To: Michael Smith
Cc: Hutton, Andrew; [email-masked]
Subject: Re: [siprec] I-D Action: draft-ietf-siprec-metadata-07.txt

This is all detailed at:

Brian

On Jul 23, 2012, at 9:34 AM, Michael Smith wrote:

>> with SIPREC and don't want to waste your time on things I simply 
>> don't understand. BTW, Brian Rosen knows me from NENA work. I'm on 
>> his LTD working group, and lead the NG9-1-1 PSAP working group, and 
>> the recording test committee. We've proposed using SIPREC as the 
>> media recording protocol in NG9-1-1.
>>