Subject: [siprec] comments on draft-ietf-siprec-metadata-07

From: "Henry Lum" <[email-masked]>
Date: Tue, 31 Jul 2012 19:26:06 -0700

Hi,

I notice that in the metadata model in section 4 CS has a 1..* to 0..* relation with a media stream and this is inconsistent with further text.

In section 6.3, CS is stating that it has a 0..* to 0..* relation with a media stream. On top of page 12 it explains that a media stream can be associated with zero of more CS and points out that a multicast MOH stream can be without a CS. In section 6.7 a media stream can connect to 1..* CS. 

Which one is the intended usage? Note that XML <stream> requires the session_id attribute so it seems like section 6.3 is odd one out.

Regards,
Henry

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 31 Jul 2012 22:59:49 -0700

Hi Henry,

Yes, I agree that there is an inconsistency.
We have also been discussing problems with this association that we plan 
to talk about on Thursday. My proposal is to change it to:

CS ------------------- Media Stream
    0..1          0..*

	Thanks,
	Paul

On 7/31/12 7:26 PM, Henry Lum wrote:
> Which one is the intended usage? Note that XML<stream>  requires the session_id attribute so it seems like section 6.3 is odd one out.
>
> Regards,
> Henry
> _______________________________________________
> siprec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siprec
>