Subject: [siprec] Editorial review comment in Metadata draft

From: "Ravindran, Parthasarathi" <[email-masked]>
Date: Mon, 23 Jul 2012 03:10:52 +0000

Hi Ram,

I noticed that the following editorial review comments in the (-07) of metadata draft

1) CSRSAssociation metadata block is not added in the metadata model whereas it is explained in Sec 6.4

2) Removal of csrc element in stream to make the schema inline with stream metadata attributes <xs:element name="csrc" type='xs:string' minOccurs='0' maxOccurs='1'

Please consider these updates in the next revision.

Thanks
Partha

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Tue, 24 Jul 2012 07:57:17 +0000

Thanks for noting these. I will make a note and update in the next
revision.

Ram

> On 23/07/12 8:40 AM, "Ravindran, Parthasarathi"
><[email-masked]> wrote:

>2) Removal of csrc element in stream to make the schema inline with
>stream metadata attributes <xs:element name="csrc" type='xs:string'
>minOccurs='0' maxOccurs='1'
>

---

From: "Simon Farrow" <[email-masked]>
Date: Tue, 24 Jul 2012 07:36:03 -0700

Ram / Andy

I have the following observations upon reviewing the pdf version 7 metadata
draft dated 3rd July 2012. I appreciate these comments are editoral but
hopefully they will helpful for the clarify of the document.

6.4.1.  Attributes

   CSRS association class has the following attributes:

   Associate-time - associate-time is calculated by SRC as the time it sees
a CS is associated to a RS

Missing 'a' before RS.

Page 38

Missing  '_id'

<participantsessionassoc

              participant_id ="zSfPoSvdSDCmU3A3TRDxAw=="

              session_id="hVpd7YQgRW2nD22h7q60JQ==">

Page 39

Missing  '_id' and stream id should be stream_id

<participantstreamassoc

              participant_id="zSfPoSvdSDCmU3A3TRDxAw==">

            <send>8zc6e0lYTlWIINA6GR+3ag==</send>

            <send>EiXGlc+4TruqqoDaNE76ag==</send>

            <recv>UAAMm5GRQKSCMVvLyl4rFw==</recv>

            <recv>i1Pz3to5hGk8fuXl+PbwCw==</recv>

          </participantstreamassoc>

          <stream_id="UAAMm5GRQKSCMVvLyl4rFw=="

              session_id="hVpd7YQgRW2nD22h7q60JQ==">

              <label>96</label>

          </stream>

          <stream_id="i1Pz3to5hGk8fuXl+PbwCw=="

              session_id="hVpd7YQgRW2nD22h7q60JQ==">

              <label>97</label>

          </stream>

          <stream_id="8zc6e0lYTlWIINA6GR+3ag=="

session_id="zSfPoSvdSDCmU3A3TRDxAw==">

              <label>98</label>

          </stream>

          <stream_id="EiXGlc+4TruqqoDaNE76ag=="

              session_id="zSfPoSvdSDCmU3A3TRDxAw==">

              <label>99</label>

          </stream>

Page 40

Missing  '_id'

<?xml version="1.0" encoding="UTF-8"?>

        <recording xmlns='urn:ietf:params:xml:ns:recording'>

          <dataMode>partial</dataMode>

            <participantstreamassoc

             participant_id ="srfBElmCRp2QB23b7Mpk0w=="

             session_id ="hVpd7YQgRW2nD22h7q60JQ==">

             <recv>8zc6e0lYTlWIINA6GR+3ag==</recv>

             <recv>EiXGlc+4TruqqoDaNE76ag==</recv>

            </participantstreamassoc>

            <participantstreamassoc

             participant_id ="zSfPoSvdSDCmU3A3TRDxAw=="

             session_id ="hVpd7YQgRW2nD22h7q60JQ==">

Page 46

Missing 's' on the first disassociate-time

<disassociate-time>2010-12-16T23:41:07Z</disassociate-time>

associate-time

The latter examples in Appendix B are continuation of earlier examples. The
associate-time is the same for all examples. For clarity should the latter
examples be later or am I missing something.

Simon Farrow
Stancil Corporation
2644 South Croddy Way
Santa Ana
CA 92704
 <http://www.stancilcorp.com> http://www.stancilcorp.com
[email-masked]
714-546-2002 ext 4311

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Tue, 24 Jul 2012 17:05:10 +0000

Hi Simon,

> On 24/07/12 8:06 PM, "Simon Farrow" <[email-masked]> wrote:

>Ram / Andy
>
>I have the following observations
>upon reviewing the pdf version 7 metadata draft dated 3rd July 2012. I
>appreciate these comments are editoral but hopefully they will helpful
>for the 
>clarify of the document.

Sure. Any comments are appreciated as it helps in making document better.
Thanks for taking time to review the document. Please see inline for
answers.

>
>
>6.4.1.  Attributes
>   CSRS 
>association class has the following attributes:
>   Associate-time 
>- associate-time is calculated by SRC as the time it sees a CS is
>associated to 
>a 
>RS
>Missing Œa¹ before RS.

Will change this in the next revision.

>Page 
>38
>Missing  Œ_id¹
>Page 
>39
>Missing  Œ_id¹ and stream id
>should be stream_id
><participantstreamassoc
>              
>Page 
>40
>Missing  Œ_id¹
><recording 
>xmlns=¹urn:ietf:params:xml:ns:recording¹>
>          

Yes. We will update the examples to be in consistent with schema and have
_id for all the element ids as you mentioned in page 38,39 and 40 and
elsewhere in the document.

> 
>Page 
>46
>Missing 
>Œs¹ on the first disassociate-time

Thanks for pointing out. I will fix in next revision.

> 
>associate-time
>The 
>latter examples in Appendix B are continuation of earlier examples. The
Yes. This needs to be changed. We have a separate document for call flows
now. We will fix the associate-time in the examples in both docs.

Thanks,
Ram

> 
>Simon Farrow
>Stancil Corporation
>2644 South Croddy 
>Way
>Santa Ana
>CA 92704
>http://www.stancilcorp.com
>714-546-2002 ext 
>4311