Subject: [Suit] I-D Action: draft-ietf-suit-manifest-00.txt

From: [email-masked]
Date: Mon, 21 Oct 2019 09:06:48 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Software Updates for Internet of Things WG of the IETF.

        Title           : SUIT CBOR manifest serialisation format
        Authors         : Brendan Moran
                          Hannes Tschofenig
                          Henk Birkholz
	Filename        : draft-ietf-suit-manifest-00.txt
	Pages           : 68
	Date            : 2019-10-21

Abstract:
   This specification describes the format of a manifest.  A manifest is
   a bundle of metadata about the firmware for an IoT device, where to
   find the firmware, the devices to which it applies, and cryptographic
   information protecting the manifest.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-suit-manifest/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-suit-manifest-00
https://datatracker.ietf.org/doc/html/draft-ietf-suit-manifest-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Rønningstad, Øyvind <[email-masked]>
Date: Fri, 25 Oct 2019 11:15:41 +0000

-----Original Message-----
From: Suit <[email-masked]> On Behalf Of [email-masked]
Sent: Monday, October 21, 2019 18:07
To: [email-masked]
Cc: [email-masked]
Subject: [Suit] I-D Action: draft-ietf-suit-manifest-00.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
Suit mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/suit

---

From: Rønningstad, Øyvind <[email-masked]>
Date: Fri, 25 Oct 2019 11:18:07 +0000

draft-ietf-suit-manifest-00 seems to be based on draft-moran-suit-manifest-04, not the latest draft-moran-suit-manifest-05.

Sorry about the double post.

Øyvind

-----Original Message-----
From: Suit <[email-masked]> On Behalf Of Rønningstad, Øyvind
Sent: Friday, October 25, 2019 13:16
To: [email-masked]
Subject: Re: [Suit] I-D Action: draft-ietf-suit-manifest-00.txt

-----Original Message-----
From: Suit <[email-masked]> On Behalf Of [email-masked]
Sent: Monday, October 21, 2019 18:07
To: [email-masked]
Cc: [email-masked]
Subject: [Suit] I-D Action: draft-ietf-suit-manifest-00.txt

Abstract:

---

From: Brendan Moran <[email-masked]>
Date: Mon, 28 Oct 2019 13:21:46 +0000

Hi Øyvind,

You’re correct. It would appear that I used the wrong base version. I’m uploading a replacement.

Best Regards,
Brendan

> On 25 Oct 2019, at 12:18, Rønningstad, Øyvind <[email-masked]> wrote:
>

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Rønningstad, Øyvind <[email-masked]>
Date: Mon, 28 Oct 2019 13:57:17 +0000

Great. Will you also fix the Full CDDL chapter? It was not updated between 04 and 05.

Øyvind

-----Original Message-----
From: Brendan Moran <[email-masked]> 
Sent: Monday, October 28, 2019 14:22
To: Rønningstad, Øyvind <[email-masked]>
Cc: [email-masked]
Subject: Re: [Suit] I-D Action: draft-ietf-suit-manifest-00.txt

Hi Øyvind,

Best Regards,
Brendan

---

From: Brendan Moran <[email-masked]>
Date: Mon, 28 Oct 2019 14:05:23 +0000

Yes, I’ll sort that out as well!

Brendan

> On 28 Oct 2019, at 13:57, Rønningstad, Øyvind <[email-masked]> wrote:
>

---

From: Brendan Moran <[email-masked]>
Date: Tue, 29 Oct 2019 09:31:04 +0000

I have now uploaded draft-ietf-suit-manifest-01 to the wg GitHub: https://github.com/suit-wg/manifest-spec

I have fixed the CDDL and the examples. Those are the only changes from my personal draft: v05.

I am working on an update that edits draft-ietf-suit-manifest-01, primarily for clarity and ease or understanding.

I will also propose splitting the examples into an associated informative draft, since the examples make up approximately 50% of the document.

Best Regards,
Brendan

> On 28 Oct 2019, at 14:05, Brendan Moran <[email-masked]> wrote:
>