<?xml version="1.0" encoding="UTF-8"?>
  <?xml-stylesheet type="text/xsl" href="rfc2629.xslt" ?>
  <!-- generated by https://github.com/cabo/kramdown-rfc version 1.7.43 (Ruby 4.0.7) -->


<!DOCTYPE rfc  [
  <!ENTITY nbsp    "&#160;">
  <!ENTITY zwsp   "&#8203;">
  <!ENTITY nbhy   "&#8209;">
  <!ENTITY wj     "&#8288;">

<!ENTITY RFC3110 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.3110.xml">
<!ENTITY RFC4033 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.4033.xml">
<!ENTITY RFC4034 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.4034.xml">
<!ENTITY RFC4035 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.4035.xml">
<!ENTITY RFC4509 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.4509.xml">
<!ENTITY RFC5155 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.5155.xml">
<!ENTITY RFC5702 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.5702.xml">
<!ENTITY RFC6840 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.6840.xml">
<!ENTITY RFC9364 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.9364.xml">
<!ENTITY RFC2065 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.2065.xml">
<!ENTITY RFC2535 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.2535.xml">
<!ENTITY RFC2536 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.2536.xml">
<!ENTITY RFC4470 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.4470.xml">
<!ENTITY RFC5011 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.5011.xml">
<!ENTITY RFC6014 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.6014.xml">
<!ENTITY RFC6605 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.6605.xml">
<!ENTITY RFC6698 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.6698.xml">
<!ENTITY RFC6725 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.6725.xml">
<!ENTITY RFC6781 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.6781.xml">
<!ENTITY RFC6975 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.6975.xml">
<!ENTITY RFC7129 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.7129.xml">
<!ENTITY RFC7344 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.7344.xml">
<!ENTITY RFC7583 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.7583.xml">
<!ENTITY RFC7646 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.7646.xml">
<!ENTITY RFC8027 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.8027.xml">
<!ENTITY RFC8078 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.8078.xml">
<!ENTITY RFC8080 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.8080.xml">
<!ENTITY RFC8145 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.8145.xml">
<!ENTITY RFC8198 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.8198.xml">
<!ENTITY RFC8509 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.8509.xml">
<!ENTITY RFC8901 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.8901.xml">
<!ENTITY RFC9077 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.9077.xml">
<!ENTITY RFC9157 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.9157.xml">
<!ENTITY RFC9276 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.9276.xml">
<!ENTITY RFC9499 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.9499.xml">
<!ENTITY RFC9558 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.9558.xml">
<!ENTITY RFC9615 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.9615.xml">
<!ENTITY RFC9718 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.9718.xml">
<!ENTITY RFC9824 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.9824.xml">
<!ENTITY RFC9859 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.9859.xml">
<!ENTITY RFC9904 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.9904.xml">
<!ENTITY RFC9905 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.9905.xml">
<!ENTITY RFC9906 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.9906.xml">
<!ENTITY RFC9975 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.9975.xml">
<!ENTITY RFC10026 SYSTEM "https://bib.ietf.org/public/rfc/bibxml/reference.RFC.10026.xml">
]>


<rfc ipr="trust200902" docName="draft-ietf-dnsop-rfc9364bis-02" category="bcp" consensus="true" submissionType="IETF" obsoletes="9364">
  <front>
    <title abbrev="DNSSEC">DNS Security Extensions (DNSSEC)</title>

    <author initials="P." surname="Hoffman" fullname="Paul Hoffman">
      <organization>ICANN</organization>
      <address>
        <email>paul.hoffman@icann.org</email>
      </address>
    </author>

    <date year="2026" month="October" day="16"/>

    
    
    

    <abstract>


<?line 66?>

<t>This document describes the DNS Security Extensions (commonly called
"DNSSEC") that are specified in RFCs 4033, 4034, and 4035, as well as
a handful of others.  One purpose is to introduce all of the RFCs in
one place so that the reader can understand the many aspects of
DNSSEC.  This document does not update any of those RFCs.  A second
purpose is to state that using DNSSEC for origin authentication of
DNS data is the best current practice.  A third purpose is to provide
a single reference for other documents that want to refer to DNSSEC.</t>

<t>This document obsoletes RFC 9364.</t>

<t>This document is being tracked at (https://github.com/paulehoffman/rfc9364bis).</t>



    </abstract>



  </front>

  <middle>


<?line 81?>

<section anchor="introduction"><name>Introduction</name>

<t>The core specification for what is known as DNSSEC (the combination of
<xref target="RFC4033"/>, <xref target="RFC4034"/>, and <xref target="RFC4035"/>) describes a set of protocols
that provide origin authentication of DNS data.  <xref target="RFC6840"/> updates
and extends those core RFCs but does not fundamentally change the way
that DNSSEC works.</t>

<t>This document lists RFCs that should be considered by someone
creating an implementation of, or someone deploying, DNSSEC as it is
currently standardized.  Although an effort was made to be thorough,
the reader should not assume this list is comprehensive.  It uses
terminology from those documents without defining that terminology.
It also points to the relevant IANA registry groups that relate to
DNSSEC.  It does not, however, point to standards that rely on zones
needing to be signed by DNSSEC, such as DNS-Based Authentication of
Named Entities (DANE) <xref target="RFC6698"/>.</t>

<t>This document obsoletes <xref target="RFC9364"/>. Changes made since <xref target="RFC9364"/> are listed in <xref target="sec-changes"/>.</t>

<section anchor="dnssec-as-a-best-current-practice"><name>DNSSEC as a Best Current Practice</name>

<t>Using the DNSSEC set of protocols is the best current practice for
adding origin authentication of DNS data.  To date, no Standards
Track RFCs offer any other method for such origin authentication of
data in the DNS.</t>

<t>More than 15 years after the DNSSEC specification was published, it
is still not widely deployed.  Recent estimates are that fewer than
10% of the domain names used for websites are signed, while around
40% of queries go to recursive resolvers that validate.  However,
this low level of deployment does not affect whether using DNSSEC is
a best current practice; it just indicates that the value of
deploying DNSSEC is often considered lower than the cost.
Nonetheless, the significant deployment of DNSSEC beneath some
top-level domains (TLDs) and the near-universal deployment of DNSSEC for
the TLDs in the DNS root zone demonstrate that DNSSEC is applicable
for implementation by both ordinary and highly sophisticated domain
owners.</t>

</section>
<section anchor="implementing-dnssec"><name>Implementing DNSSEC</name>

<t>Developers of validating resolvers and authoritative servers, as well
as operators of validating resolvers and authoritative servers, need
to know the parts of the DNSSEC protocol that would affect them.
They should read the DNSSEC core documents and probably at least be
familiar with the extensions.  Developers will probably need to be
very familiar with the algorithm documents as well.</t>

<t>As a side note, some of the DNSSEC-related RFCs have significant
errata, so reading the RFCs should also include looking for the
related errata.</t>

</section>
</section>
<section anchor="dnssec-core-documents"><name>DNSSEC Core Documents</name>

<t>What we refer to as "DNSSEC" is the third iteration of the DNSSEC
specification; <xref target="RFC2065"/> was the first, and <xref target="RFC2535"/> was the second.
Earlier iterations have not been deployed on a significant scale.
Throughout this document, "DNSSEC" means the protocol initially
defined in <xref target="RFC4033"/>, <xref target="RFC4034"/>, and <xref target="RFC4035"/>.</t>

<t>The three initial core documents generally cover different topics:</t>

<t><list style="symbols">
  <t><xref target="RFC4033"/> is an overview of DNSSEC, including how it might change
the resolution of DNS queries.</t>
  <t><xref target="RFC4034"/> specifies the DNS resource records used in DNSSEC.  It
obsoletes many RFCs about earlier versions of DNSSEC.</t>
  <t><xref target="RFC4035"/> covers the modifications to the DNS protocol incurred by
DNSSEC.  These include signing zones, serving signed zones,
resolving in light of DNSSEC, and authenticating DNSSEC-signed
data.</t>
</list></t>

<t>At the time this set of core documents was published, someone could
create a DNSSEC implementation of signing software, of a DNSSEC-aware
authoritative server, and/or of a DNSSEC-aware recursive resolver
from the three core documents, plus a few older RFCs specifying the
cryptography used.  Those two older documents are the following:</t>

<t><list style="symbols">
  <t><xref target="RFC2536"/> defines how to use the DSA signature algorithm (although
it refers to other documents for the details).  DSA was thinly
implemented and can safely be ignored by DNSSEC implementations.</t>
  <t><xref target="RFC3110"/> defines how to use the RSA signature algorithm (although
refers to other documents for the details).  RSA is still among
the most popular signing algorithms for DNSSEC.</t>
</list></t>

<t>It is important to note that later RFCs update the core documents.
As just one example, <xref target="RFC9077"/> changes how TTL values are calculated
in DNSSEC processing.</t>

<section anchor="addition-to-the-dnssec-core"><name>Addition to the DNSSEC Core</name>

<t>As with any major protocol, developers and operators discovered
issues with the original core documents over the years.  <xref target="RFC6840"/> is
an omnibus update to the original core documents and thus itself has
become a core document.  In addition to covering new requirements
from new DNSSEC RFCs, it describes many important security and
interoperability issues that arose during the deployment of the
initial specifications, particularly after the DNS root was signed in
2010.  It also lists some errors in the examples of the core
specifications.</t>

<t><xref target="RFC6840"/> brings a few additions into the core of DNSSEC.  It makes
NSEC3 <xref target="RFC5155"/> as much a part of DNSSEC as NSEC is.  It also makes
the SHA-256 and SHA-512 hash functions defined in <xref target="RFC4509"/> and
<xref target="RFC5702"/> part of the core.</t>

</section>
</section>
<section anchor="additional-cryptographic-algorithms-and-dnssec"><name>Additional Cryptographic Algorithms and DNSSEC</name>

<t>Current cryptographic algorithms typically weaken over time as
computing power improves and new cryptoanalysis emerges.  Two new
signing algorithms have been adopted by the DNSSEC community:
Elliptic Curve Digital Signature Algorithm (ECDSA) <xref target="RFC6605"/> and
Edwards-curve Digital Signature Algorithm (EdDSA) <xref target="RFC8080"/>.  ECDSA
and EdDSA have become very popular signing algorithms in recent
years.  The GOST signing algorithm <xref target="RFC9558"/> was also adopted but
has seen very limited use, likely because it is a national algorithm
specific to a very small number of countries;
<xref target="RFC9906"/> deprecated its use.</t>

<t>Implementation developers who want to know which algorithms to
implement in DNSSEC software should refer to <xref target="RFC9904"/>.  Note that
this specification is only about what algorithms should and should
not be included in implementations, i.e., it is not advice about
which algorithms zone operators should or should not use for signing,
nor which algorithms recursive resolver operators should or should
not use for validation.</t>

<t><xref target="RFC9905"/> updates <xref target="RFC4034"/> and <xref target="RFC4035"/>.</t>

</section>
<section anchor="extensions-to-dnssec"><name>Extensions to DNSSEC</name>

<t>The DNSSEC community has extended the DNSSEC core and the
cryptographic algorithms, both in terms of describing good
operational practices and in new protocols.  Some of the RFCs that
describe these extensions include the following:</t>

<t><list style="symbols">
  <t><xref target="RFC5011"/> describes a method to help resolvers update their DNSSEC
trust anchors in an automated fashion.  This method was used in
2018 to update the DNS root trust anchor.</t>
  <t><xref target="RFC6781"/> is a compendium of operational practices that may not be
obvious from reading just the core specifications.</t>
  <t><xref target="RFC7344"/> describes using the CDS and CDNSKEY resource records to
help automate the maintenance of DS records in the parents of
signed zones.  (This document was updated by <xref target="RFC9975"/>.)</t>
  <t><xref target="RFC8078"/> extends <xref target="RFC7344"/> by showing how to do initial setup of
trusted relationships between signed parent and child zones.</t>
  <t><xref target="RFC8198"/> describes how a validating resolver can emit fewer
queries in signed zones that use NSEC and NSEC3 for negative
caching.</t>
  <t><xref target="RFC9077"/> updates <xref target="RFC8198"/> with respect to the TTL fields in
signed records.</t>
  <t><xref target="RFC9824"/> "describes a technique to generate a signed DNS response
on demand for a nonexistent name by claiming that the name exists but
doesn't have any data for the queried record type".</t>
  <t><xref target="RFC9975"/> clarifies consistency requirements for CDS and CDNSKEY
resource records originally described in <xref target="RFC7344"/> and used for
automatic maintenance of DS records.</t>
  <t><xref target="RFC10026"/>, a Best Current Practice as well, provides guidelines
for implementing DS record automation interoperably across suffixes
(usually TLDs), with recommendations on aspects like acceptance checks,
timing, and locks.</t>
</list></t>

</section>
<section anchor="additional-documents-of-interest"><name>Additional Documents of Interest</name>

<t>The documents listed above constitute the core of DNSSEC, the
additional cryptographic algorithms, and the major extensions to
DNSSEC.  This section lists some additional documents that someone
interested in implementing or operating DNSSEC might find of value:</t>

<t><list style="symbols">
  <t><xref target="RFC4470"/> "describes how to construct DNSSEC NSEC resource records
that cover a smaller range of names than called for by <xref target="RFC4034"/>.
By generating and signing these records on demand, authoritative
name servers can effectively stop the disclosure of zone contents
otherwise made possible by walking the chain of NSEC records in a
signed zone".</t>
  <t><xref target="RFC6975"/> "specifies a way for validating end-system resolvers to
signal to a server which digital signature and hash algorithms
they support".</t>
  <t><xref target="RFC7129"/> "provides additional background commentary and some
context for the NSEC and NSEC3 mechanisms used by DNSSEC to
provide authenticated denial-of-existence responses".  This
background is particularly important for understanding NSEC and
NSEC3 usage.</t>
  <t><xref target="RFC7583"/> "describes the issues surrounding the timing of events
in the rolling of a key in a DNSSEC-secured zone".</t>
  <t><xref target="RFC7646"/> "defines Negative Trust Anchors (NTAs), which can be
used to mitigate DNSSEC validation failures by disabling DNSSEC
validation at specified domains".</t>
  <t><xref target="RFC8027"/> "describes problems that a Validating DNS resolver,
stub-resolver, or application might run into within a non-
compliant infrastructure".</t>
  <t><xref target="RFC8145"/> "specifies two different ways for validating resolvers
to signal to a server which keys are referenced in their chain of
trust".</t>
  <t><xref target="RFC9499"/> contains lists of terminology used when talking about
DNS; Sections 10 and 11 cover DNSSEC.</t>
  <t><xref target="RFC8509"/> "specifies a mechanism that will allow an end user and
third parties to determine the trusted key state for the root key
of the resolvers that handle that user's DNS queries".</t>
  <t><xref target="RFC8901"/> "presents deployment models that accommodate this
scenario [when each DNS provider independently signs zone data
with their own keys] and describes these key-management
requirements".</t>
  <t><xref target="RFC9276"/> "provides guidance on setting NSEC3 parameters based on
recent operational deployment experience".</t>
  <t><xref target="RFC9615"/> "allows managed DNS operators to securely announce
DNSSEC key parameters for zones under their management, including for
zones that are not currently securely delegated".</t>
  <t><xref target="RFC9718"/> "describes the format and publication mechanisms IANA
has used to distribute the DNSSEC trust anchors".</t>
  <t><xref target="RFC9859"/> "generalizes and extends the use of DNS NOTIFY ... to allow other types of actions that were previously lacking a trigger mechanism to be triggered via the DNS." The primary action described in the RFC is a new DSYNC record that indicates that "a parent would like child operators to send them a NOTIFY message upon publication of a new CDS/CDNSKEY/CSYNC RRset".</t>
</list></t>

</section>
<section anchor="iana-considerations"><name>IANA Considerations</name>

<t>IANA already has three registry groups that relate to DNSSEC:</t>

<t><list style="symbols">
  <t><eref target="https://www.iana.org/assignments/dns-sec-alg-numbers">DNSSEC algorithm numbers</eref></t>
  <t><eref target="https://www.iana.org/assignments/dnssec-nsec3-parameters">DNSSEC NSEC3 parameters</eref></t>
  <t><eref target="https://www.iana.org/assignments/ds-rr-types">DNSSEC DS RRtype digest algorithms</eref></t>
</list></t>

<t>The rules for the DNSSEC algorithm registry were set in the core RFCs
and updated by <xref target="RFC6014"/>, <xref target="RFC6725"/>, and <xref target="RFC9157"/>.</t>

<t><xref target="RFC9904"/> updates <xref target="RFC9157"/>.</t>

<t>This document does not update or create any registry groups or
registries.</t>

</section>
<section anchor="security-considerations"><name>Security Considerations</name>

<t>All of the security considerations from all of the RFCs referenced in
this document apply here.</t>

</section>


  </middle>

  <back>


<references title='References' anchor="sec-combined-references">

    <references title='Normative References' anchor="sec-normative-references">

&RFC3110;
&RFC4033;
&RFC4034;
&RFC4035;
&RFC4509;
&RFC5155;
&RFC5702;
&RFC6840;
&RFC9364;


    </references>

    <references title='Informative References' anchor="sec-informative-references">

&RFC2065;
&RFC2535;
&RFC2536;
&RFC4470;
&RFC5011;
&RFC6014;
&RFC6605;
&RFC6698;
&RFC6725;
&RFC6781;
&RFC6975;
&RFC7129;
&RFC7344;
&RFC7583;
&RFC7646;
&RFC8027;
&RFC8078;
&RFC8080;
&RFC8145;
&RFC8198;
&RFC8509;
&RFC8901;
&RFC9077;
&RFC9157;
&RFC9276;
&RFC9499;
&RFC9558;
&RFC9615;
&RFC9718;
&RFC9824;
&RFC9859;
&RFC9904;
&RFC9905;
&RFC9906;
&RFC9975;
&RFC10026;


    </references>

</references>


<?line 316?>

<section anchor="sec-changes"><name>Changes Since RFC 9364</name>

<t>This document obsoletes <xref target="RFC9364"/>.</t>

<t>The main changes from that document are:</t>

<t><list style="symbols">
  <t><xref target="RFC9558"/> was added to this document</t>
  <t>RFC 7958 became <xref target="RFC9718"/></t>
  <t>RFC 8499 became <xref target="RFC9499"/></t>
  <t>RFC 8624 became <xref target="RFC9904"/></t>
  <t>Added <xref target="RFC9615"/></t>
  <t>Added <xref target="RFC9824"/></t>
  <t>Added <xref target="RFC9859"/></t>
  <t>Added <xref target="RFC9905"/></t>
  <t>Added <xref target="RFC9906"/></t>
  <t>Added <xref target="RFC9975"/></t>
  <t>Added <xref target="RFC10026"/></t>
</list></t>

</section>
<section anchor="acknowledgements"><name>Acknowledgements</name>

<t>The DNS world owes a depth of gratitude to the authors and other
contributors to the core DNSSEC documents and to the notable DNSSEC
extensions.</t>

</section>


  </back>

<!-- ##markdown-source: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-->

</rfc>

