Subject: RE: FW: Adding Enterprise MIB for the T1/E1 stuff at the DS0 leve l.

From: [email-masked] (Alan Bartky)
Date: Tue, 27 Jan 98 07:43:50 PST

Dave,

As far as signaling bit definitions, they are for one listed
in ANSI T1.403-1995, Annex C (normative) Robbed-bit signaling
state definitions for channelized DS1 interfaces.

And according to one of the sites on the Web I've seen on
signaling, they are also listed in

  - T1 Channel Bank (ATT Pub 43801)

  - E1 Channelization (CCITT Recomendation G.732)

As far as adding something new to the MIB to support signaling
and Idle code, RFC 1406 already has an object to support
what basic type of signaling is there:

         dsx1SignalMode OBJECT-TYPE
             SYNTAX  INTEGER {
                         none (1),
                         robbedBit (2),
                         bitOriented (3),
                         messageOriented (4)
                     }
             ACCESS  read-write
             STATUS  mandatory
             DESCRIPTION
                "'none' indicates that no bits are reserved for
                signaling on this channel.

                 'robbedBit' indicates that T1 Robbed Bit  Sig-
                naling is in use.

                 'bitOriented' indicates that E1 Channel  Asso-
                ciated Signaling is in use.

                 'messageOriented' indicates that Common  Chan-
                nel Signaling is in use either on channel 16 of
                an E1 link or channel 24 of a T1."
            ::= { dsx1ConfigEntry 11 }

And the draft MIB also has an object that tells if the
interface is channelized or not:

          dsx1Channelization  OBJECT-TYPE
               SYNTAX      INTEGER {
                              enabled(1),
                              disabled(2)
                           }
               MAX-ACCESS  read-only
               STATUS      current
               DESCRIPTION
                      "Indicates whether this ds1/e1 is channelized or
                      unchannelized.  The value of enabled indicates
                      channelized.  "
               DEFVAL { enabled }
          ::=3D { dsx1ConfigEntry 20 }

As far as signaling goes beyond those definitions, it is my opinion
that how the bits are interpreted is "above" the DS1 layer.  In addition
when using T1 multiplexers, it is possible that you could mix different
PBXs with different interpretations of those bits for the time
slots assigned to them.

We don't currently have our own private MIB object to look at 
these bits, but were pretty much considering that they
be added in our private Circuit emulation MIB for how the
signaling bits were to be interpreted for a given set of time slots.

As far as Idle fill code, that again is in our Circuit Emulation private
MIB as it is used to program our AAL1 SAR, and at least for us
was more appropriate at the circuit emulation level:

	atmxCesVccIdleCode   OBJECT-TYPE
	     SYNTAX INTEGER (0..'ff'h)
	     ACCESS read-write
	     STATUS mandatory
	     DESCRIPTION
	        "The idle character sent to service emulation interface
                 or to ATM uplink if data is not available."
             ::= { atmxCesVccEntry 15 }	     	     

Regards,

Alan 1/27/98 7:42

***********************************************************************
*   /\                                                                *
*  /\/\    Alan K. Bartky                       Email:[email-masked]  *
* /\  /\   Manager, WAN Software Development                          *
* \/  \/   XYLAN Corporation                    Voice:(714) 450-9162  *
*  \/\/    1 TECHNOLOGY DR STE J709             FAX:  (714) 450-9170  *
*   \/     IRVINE CA 92618-2353                                       *
*  XYLAN                                                              *
***********************************************************************

> From [email-masked] Mon Jan 26 07:09:17 1998
> From: "Chen, David" <[email-masked]>
> To: "[email-masked]'" <[email-masked]>,
>         Dave Fowler
> 	 <[email-masked]>
> Cc: "Leonard, John" <[email-masked]>,
>         "Dong Xie (E-mail)"
> 	 <[email-masked]>,
>         "Jack Ruroede (E-mail)" <[email-masked]>,
>         "Kennedy, Rick" <[email-masked]>, [email-masked],
>         "Chen, David" <[email-masked]>
> Subject: RE: FW: Adding Enterprise MIB for the T1/E1 stuff at the DS0 leve
> 	l.
> Date: Mon, 26 Jan 1998 10:01:43 -0500
> X-Priority: 3
> Mime-Version: 1.0
> X-Mailer: Internet Mail Service (5.0.1458.49)
> Content-Type> : > text/plain> ; > charset="iso-8859-1"> 
> Content-Length: 5444
> 
> Roy,
> 
> Does anyone happen to know what are those ANSI, ITU and FRENCH standard
> documentation numbers? 
> 
> Regards,
> Dave
> 
> > -----Original Message-----
> > From:	[email-masked] [SMTP:[email-masked]]
> > Sent:	Monday, January 26, 1998 9:29 AM
> > To:	Dave Fowler
> > Cc:	Leonard, John; Chen, David; Dong Xie (E-mail); Jack Ruroede
> > (E-mail); Kennedy, Rick; [email-masked]
> > Subject:	Re: FW: Adding Enterprise MIB for the T1/E1 stuff at the
> > DS0 level.
> > 
> > Dave,
> > 
> > I am concerned with this contribution.  I know there are three
> > standards for
> > ABCD signaling bits:  ANSI, ITU, and FRENCH.  Unfortunately they are
> > not
> > identical.  In addition, I have been told that some PBX vendors use
> > non-standard signaling methods.
> > 
> > This proposal need more research.  I am not fully aware of all the
> > ramifications.
> > 
> > Regards,
> > Roy
> > 
> > Dave Fowler wrote:
> > 
> > > Leonard, John wrote:
> > > >
> > > > Hi Dave,
> > > >
> > > > One of our people here, Dave Chen, asked me about a managed object
> > for
> > > > ds0 trunk conditioning he would like to see implemented to help
> > with ATM
> > > > circuit emulation. He feels that it may be of general interest and
> > not
> > > > just for ATM circuit emulation, so I thought that I'd get your
> > opinion
> > > > on possibly adding it to the  Definitions of Managed Objects for
> > the DS0
> > > > and DS0 Bundle Interface Type IETF draft MIBs you've been working
> > on.
> > > > This could go into the ds0ConfigEntry as one or more enumerated
> > > > INTEGERs.
> > > >
> > > > Thanks,
> > > > John
> > >
> > > Thanks for the contribution.  Does any one think this is useful in
> > the
> > > general case, or should it go in a Circ Emulation type MIB?
> > >
> > > Regards,
> > > David
> > > >
> > > > > John Leonard, Lucent Technologies, MMIT
> > > > > 300 Baker Ave. Suite 100, Concord, MA 01742-2168
> > > > > vox: +1.978.287.2893 fax: +1.978.287.2810 internet:
> > > > > [email-masked]
> > > > >
> > > > > -----Original Message-----
> > > > > From: Chen, David
> > > > > Sent: Thursday, January 15, 1998 9:17 AM
> > > > > To:   Leonard, John
> > > > > Cc:   Chen, David
> > > > > Subject:      Adding Enterprise MIB for the T1/E1 stuff at the
> > DS0
> > > > > level.
> > > > >
> > > > > John,
> > > > >
> > > > > The following data structure are new to any existing MIB which
> > are
> > > > > required for the ATM Circuit Emulation Service.
> > > > >
> > > > > I think this better fits into a Enterprise DS0 level MIB data
> > > > > strucutre. Let me know if you have any questions.
> > > > >
> > > > > ============== New Data Structure
> > ===============================
> > > > > typedef struct DS0TRUNKCOND
> > > > > {
> > > > >   UINT8      rcvSignalingCode;  //signaling bits apply to
> > receiving
> > > > > AB(CD)
> > > > >   UINT8      troubleCode;         //bits apply to ds0 data
> > > > >   UINT8      xmtSignalingCode;//signaling bits apply to
> > transmitting
> > > > > AB(CD)
> > > > >   UINT8      idleCode;              //bytes apply to ds0 when
> > out of
> > > > > service
> > > > >   INT32      status;                  //trunk conditioning
> > states
> > > > >   INT32      mode;                   //decide trunk condition
> > > > > capability is avtivated or not
> > > > > }T1E1TC;
> > > > >
> > > > > ============================================================
> > > > >
> > > > >
> > > > >
> > //////////////////////////////////////////////////////////////////////
> > > > > ///////////////////////////////
> > > > > //
> > > > > //   Bit Format:  rcvSignalingCode & xmtSignalingCode, value
> > ranges
> > > > > from 0 to 0xFF
> > > > > //
> > > > > //                (MSB) 0bABCDabcd (LSB)
> > > > > //                              --------          ==> signaling
> > bits
> > > > > for Discconect
> > > > > //                                       -------  ==> signaling
> > bits
> > > > > for Busy-out
> > > > > //
> > > > >
> > //////////////////////////////////////////////////////////////////////
> > > > > ///////////////////////////////
> > > > >
> > > > > //Possible states for T1E1TC status
> > > > >
> > > > > #define DS0_TRUNKCOND_NONE                   0x00000 //no trunk
> > > > > condition applied
> > > > >
> > > > > #define DS0_TRUNKCOND_RCV_ONHOOK      0x00001 //apply (2.5)
> > second for
> > > > > Disconnect
> > > > > #define DS0_TRUNKCOND_RCV_OFFHOOK    0x00002 //apply forever for
> > > > > busy-out
> > > > > #define DS0_TRUNKCOND_RCV_CODE           0x00004
> > > > > #define DS0_TRUNKCOND_RCV_NONE
> > ~(DS0_TRUNKCOND_RCV_ONHOOK |
> > > > > DS0_TRUNKCOND_RCV_OFFHOOK | DS0_TRUNKCOND_RCV_CODE)
> > > > >
> > > > > #define DS0_TRUNKCOND_XMT_ONHOOK      0x00008
> > > > > #define DS0_TRUNKCOND_XMT_OFFHOOK    0x00010
> > > > > #define DS0_TRUNKCOND_XMT_CODE           0x00020
> > > > > #define DS0_TRUNKCOND_XMT_NONE
> > ~(DS0_TRUNKCOND_XMT_ONHOOK |
> > > > > DS0_TRUNKCOND_XMT_OFFHOOK | DS0_TRUNKCOND_XMT_CODE)
> > > > >
> > > > > #define DS0_TRUNKCOND_INIT                     0x80000
> > > > >
> > > > >
> > > > > #define DSX1MAXDS0_TRUNKCOND              31
> > > > > T1E1TC       ds0TrunkCond[DSX1MAXDS0_TRUNKCOND];
> > > > >
> > > > >
> > > > > Regards,
> > > > >      Dave
> > >
> > > --
> > > David Fowler                                   email:
> > > [email-masked]
> > > Newbridge Networks Corporation                 voice: (613) 599-3600
> > > ext.6559
> > > 600 March Rd, Kanata, Ontario, Canada K2K 2E6  fax:   (613) 599-3619
> > 
> > 
> > 
> > --
> > Roy Spitzer                             Telogy Networks
> > Phone (301) 515-6531                    20250 Century Boulevard
> > FAX:  (301) 515-7687                    Germantown, Maryland 20874
> > email [email-masked]
> > 
> > 
>

---

From: James Watt <[email-masked]>
Date: Thu, 29 Jan 1998 17:23:26 -0500

Last time I looked at some other proprietary MIBs, there was both a
"seized" and an "idle" code so that standard trunk conditioning could be
properly implement. The assertion was with the two objects, just with bits,
you can do any kind of trunk conditioning needed and not worry about what
various people might/or might not do over there own AB[CD].    This would
match the struct shown below.  Another objects was used to see
what signalling bits are being received.

The notion is not to get hung up on what the signalling protocol is
required but rather let someone else build the UI that shields the user
from bit patterns.

This would seem to be something to add to the DS0 MIB.

Regards,
-james

ps Wrt to the "number of definitions", at one point it seemed that each of
the non-North American PTTs had their own definition of how to carry
analogue line signalling, e.g for E&Ms or ground start, over E1 (aka CEPT
2Mbits/s) trunks.  Some of them even matched...

>> > > > > T1E1TC       ds0TrunkCond[DSX1MAXDS0_TRUNKCOND];

_____________________________________________________________
James W. Watt,          [email-masked]              Ph :+1 613 591 3600
Newbridge Networks  600 March Rd Kanata ON Canada K2K 2E6  FAX:+1 613 591 3680