Subject: DS3 Intervals w/ If down

From: Eric Bomarsi <[email-masked]>
Date: Wed, 28 Jan 1998 17:23:49 -0500

How is the DS3 Interval table supposed to be handled
when the interface is set to "down". Is interval 
accumulation suspended until the interface mode is 
set to 'up'? 

Thanks in advance,
Eric Bomarsi

---

From: Dave Fowler <[email-masked]>
Date: Fri, 30 Jan 1998 13:42:53 -0500

> accumulation suspended until the interface mode is

Interval accumulation is not suspended.

-- 
David Fowler                                   email:
[email-masked]
Newbridge Networks Corporation                 voice: (613) 599-3600 
ext.6559
600 March Rd, Kanata, Ontario, Canada K2K 2E6  fax:   (613) 599-3619

---

From: Rajesh Abbi <[email-masked]>
Date: Fri, 30 Jan 1998 15:49:45 -0500

Dave and Eric,

I would think the PM data collection should stop if the interface
is "down".  In the "down" state the interface is not supposed to
be transmitting/receiving any data, and may in fact be powered
down.  Thus collecting PM data is meaningless.

Interval(s) over which an interface is "down" must be marked
as "Invalid" (ie: xxxIntervalValidData = False).

========================================================================
Rajesh Abbi
Alcatel Network Systems
2912 Wake Forest Road
Raleigh, NC 27609-7860
Phone: (919) 850-6194
Fax  : (919) 850-6670
Email: [email-masked]
========================================================================

---

From: Eric Bomarsi <[email-masked]>
Date: Fri, 30 Jan 1998 16:54:58 -0500

> down.  Thus collecting PM data is meaningless.

Yes - unless you simply continue interval accumulation
by incrementing UASs only. That was also suggested, and seems
to make sense. There are a few different ways to handle this 
so I think the method should be made clear in the MIB for 
product consistency.

/Eric Bomarsi

---

From: Dave Fowler <[email-masked]>
Date: Sun, 01 Feb 1998 11:04:39 -0500

> so I think the method should be made clear in the MIB for

Fine with me!  I'll make the clarifications  (but only because I have to
churn the MIB again anyway :) ) .  But let me explain the semantics of
the
interval number for completeness.  Interval number 1 represents the
complete interval
closest to the current time.  For example, if it is 2:10, then interval
number
1 represents data that is collected from 1:45 to 2:00.  Once it is
2:15:01,
interval number 1 should now represent data from 2:00 to 2:15.  

Therefore, it is necessary to "age" the intervals even when the
interface is down.
And UAS should be getting incremented as mentioned above.

The interval business certainly can be confusing and I will attempt to
fix it in
the next (and hopefully final) draft.....

Regards,
David