Subject: [Stackevo] Winding up the Stack Evolution Program

From: Brian Trammell (IETF) <[email-masked]>
Date: Mon, 20 May 2019 09:59:48 +0000

Greetings, all,

At the IAB retreat last week, as part of a review of the structure of its programs, the IAB discussed the future of the Stack Evolution program, and has decided that once draft-thomson-use-it-or-lose-it has been sent up to the IAB as a whole, that the program should be closed in its present form. 

I, personally, consider this a declaration of victory, and thank you all for your work and the discussions over the past few years. 

The initial concept behind the IP Stack Evolution program, investigating how changes to the transport layer could be deployed in the big-I Internet, and explore the impact of encryption at the transport layer on evolution of the stack. At the time the program started, there was not much work yet in and around the IETF in this space. 

That has changed. TAPS has been chartered (and is well on its way to defining an abstract interface that reduces the rigidness of the binding between interfaces and transports). QUIC has demonstrated that it is possible to deploy a new transport protocol at scale, and nearly finished an IETF standard version of that protocol. Conversations (many conversations) have started about the balance of measurability and confidentiality, in the form of the QUIC spin bit. A wider discussion about the history of transport-layer signaling, and what we can learn from it going forward, is ongoing in PANRG. 

There two possible next steps for the program as I see it:

(1) declare victory, close, and continue the discusson in the IETF and in the hallways; and/or

(2) determine if there is follow-on work to be coordinated by and with the IAB, and if so, propose a description for a follow-on program. 

If there's interest in (2), please let us know on the stackevo@ list.

Thanks, cheers,

Brian (outgoing IAB lead)

---

From: "Aaron Falk" <[email-masked]>
Date: Mon, 20 May 2019 09:40:17 -0400

Hi Brian-

I agree that the topics that have been coming up lately differ enough 
from the original goals of the program that if it continues it would 
really be a different thing than originally chartered.  Closing it seems 
like a reasonable thing to do.  This makes me sad as the program 
meetings have been some of the more interesting and ‘distant 
horizon’ discussions that I get during the IETF week.  I was 
contemplating proposing those who are interested continue as a lunch 
group or something but I think without the IAB involvement it may not 
lead to much.  I’m interested in other’s opinions.

--aaron

On 20 May 2019, at 5:59, Brian Trammell wrote:

> Greetings, all,
>
> At the IAB retreat last week, as part of a review of the structure of 
> its programs, the IAB discussed the future of the Stack Evolution 
> program, and has decided that once draft-thomson-use-it-or-lose-it has 
> been sent up to the IAB as a whole, that the program should be closed 
> in its present form.
>
> I, personally, consider this a declaration of victory, and thank you 
> all for your work and the discussions over the past few years.
>
> The initial concept behind the IP Stack Evolution program, 
> investigating how changes to the transport layer could be deployed in 
> the big-I Internet, and explore the impact of encryption at the 
> transport layer on evolution of the stack. At the time the program 
> started, there was not much work yet in and around the IETF in this 
> space.
>
> That has changed. TAPS has been chartered (and is well on its way to 
> defining an abstract interface that reduces the rigidness of the 
> binding between interfaces and transports). QUIC has demonstrated that 
> it is possible to deploy a new transport protocol at scale, and nearly 
> finished an IETF standard version of that protocol. Conversations 
> (many conversations) have started about the balance of measurability 
> and confidentiality, in the form of the QUIC spin bit. A wider 
> discussion about the history of transport-layer signaling, and what we 
> can learn from it going forward, is ongoing in PANRG.
>
> (2) determine if there is follow-on work to be coordinated by and with 
> the IAB, and if so, propose a description for a follow-on program.
>
> _______________________________________________
> Stackevo mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/stackevo

---

From: "Martin Thomson" <[email-masked]>
Date: Mon, 20 May 2019 15:40:43 +0100

This was definitely a concern from those in the IAB also.  A side meeting at lunch (or at another time) would be welcome.

On Mon, May 20, 2019, at 14:40, Aaron Falk wrote:
> meetings have been some of the more interesting and ‘distant horizon’ 
> discussions that I get during the IETF week. I was contemplating 
> proposing those who are interested continue as a lunch group or 
> something but I think without the IAB involvement it may not lead to 
> much. I’m interested in other’s opinions.
> 
> --aaron
>

---

From: "Brian Trammell (IETF)" <[email-masked]>
Date: Tue, 21 May 2019 10:12:24 +0000

hi Aaron,

Personal opinions only here.

> On 20 May 2019, at 13:40, Aaron Falk <[email-masked]> wrote:
> 
> Hi Brian-
> 
> I agree that the topics that have been coming up lately differ enough from the original goals of the program that if it continues it would really be a different thing than originally chartered. Closing it seems like a reasonable thing to do. This makes me sad as the program meetings have been some of the more interesting and ‘distant horizon’ discussions that I get during the IETF week.

Indeed, it seems to me (personally) that stackevo-the-program had become stackevo-the-lunch-club, at least in terms of its value to the participants. I'd be happy to make it a standing lunch, but it doesn't need to be an IAB program for that.

>  I was contemplating proposing those who are interested continue as a lunch group or something but I think without the IAB involvement it may not lead to much. 

I'm not sure why this is the case? Most of the activity that came out of stackevo, aside from the workshops, have happened through the IETF processes. 

Even workshops on some stack evolution topics became infeasible to do through the IAB process. The MAMI project ran the M3S workshop before IETF101 on its own, because the noise around kinda-related TLS interception discussions had been turned up so as to make any discussion in an IAB or IETF space impossible.

As long as at least one IAB member joins the lunch, good ideas that come out of it that actually do need IAB involvement can be sent up. And if not, [email-masked] is always open to coherent requests for help. :)

Cheers,

Brian

> I’m interested in other’s opinions.
> 
> --aaron
>